Filling in additional fields stopped working in 7.4 (Windows)

Since the update to 7.4, filling in additional fields (like the field "Verfügername", 2nd field from the top) on this login site https://login.hellobank.at/portal-login/ has stopped working. I've already deleted and re-created the login (by choosing save when I log in the fist time) and by manually saving the login as described here https://support.1password.com/save-login-manually/.

The corresponding information gets saved correctly in 1Password for the correct domain, but it isn't filled in correctly.

Version information:
1Password: 7.4.759 (but started happening with 7.4.750)
OS: Windows 10
Browser: Firefox 68.6.0
Browser extension: 4.7.5.90


1Password Version: 7.4.759
Extension Version: 4.7.5.90
OS Version: Windows 10
Sync Type: Dropbox

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @jives ,
    The latest Windows update was a big one, and it included a new autofilling engine. I see that the issue on this website is caused by the username field, which is set as a password type but its name is actually "username" which throws our AI off.

    I will file this issue for our developers to take a look at. In the meantime, here's a little something you can do to make things easier:
    1. When you get to the login page autofill it with 1Password so that the first and last filled will get autofilled.
    2. Open the 1Password extension by clicking it on the top right corner of your browser, right click the login for this website -> select "More" -> select the second field's name and copy/paste it or select your browser's window from the list of options and it will autofill it as well.

    Thanks for reporting this!

  • Hi @Yaron,

    Thanks a lot for looking into this! No worries, I imagine all those corner cases are quite tricky to deal with.
    I've been using your proposed workaround in the meantime, and it it works well :+1:

  • ag_yaronag_yaron

    Team Member

    Thanks for letting me know @jives
    Indeed, every website is different and we're working on improving 1Password's autofilling 24/7, but it is an endless job.

    Hopefully we will be able to improve 1Password's abilities on this particular website in the near future.

  • SInce approx. 1-2 month I have the same issue!
    But it worked before for at least approx. 1 year.
    OS: 10.15.6
    1Password: 7.6
    Browser: firefox 79.0

    Deleting the old login and creating a new (on the fly) also doesn't solve the issue

    I am currently using the described workaround but that was not the reason I subscribed 1Password.
    According to the release notes it should have been fixed in 1.19.00 (2020-04-24), it had issue #1191.
    I made some screenshots I could send if it might of any use for you.

    Best regards

  • ag_anaag_ana

    Team Member

    @falo_user:

    According to the release notes it should have been fixed in 1.19.00 (2020-04-24), it had issue #1191.

    Indeed. What version of the 1Password browser extension are you currently using? I believe that's the only part from your configuration that you left out from your post.

  • Hello ag_ana

    Thank you for the feedback.
    The 1Password extension is Version 4.7.5.90, last updated June 25th, 2019; Auto-Update setting is "Standard"
    Need the extensions be updated seperately? I always thought they update with the browser's updates, so I did not thought of them in the configuration list... ;-)

    Shall I update the extension first before trying a new attempt or is the extension up-to-date?

  • ag_anaag_ana

    Team Member

    @falo_user:

    Thank you for the confirmation! You are using the companion browser extension then, but you are looking at the changelog for 1Password X, which is a separate extension ;) If you want to give 1Password X a try, you can download it from here (you will need a 1Password Membership for that).

  • Oh, now you confused me a bit. I am using 1 Password 7 and now you talk about 1Password X, is sounds like there are different branches or products around. I thought there is just ONE 1Password.
    I would just want(ed) to know what to do so that my hellobank login works...

  • Just watched the video. I think I got it: 1Password X is the "new" Browser extension I should use together with 1 Password 7. So do I get it right that I just need to "deinstall" the current "companion" browser extension and just install the 1PW X?

  • ag_yaronag_yaron

    Team Member

    Hey @falo_user ,
    Sorry for the confusion there.

    Yes, we currently offer two different extensions:

    • "1Password extension (desktop app required)" is our good old companion extension that allows the 1Password 7 desktop app to autofill and interact with your browser.
    • "1Password X" is our newest extension and works independently from the desktop app. It connects directly to your 1Password.com cloud account and works with your data there, allowing you to save and autofill in your browser even if you don't have the desktop app installed. It also offers new autofilling experience and features.

    We do recommend 1Password X so feel free to disable/remove the companion extension and give 1Password X a go. You can always go back, but I'm certain that after a couple of days of using 1Password X you wouldn't want to go back to the companion extension :)

  • Hello ag_yaron

    Today I installed the 1PW X extension in Firefox (80.0), 1 PW X extension version 1.21.0.
    But I do not see the 1PW icon in the browser top bar.
    I also (first) disabled the "good old companion". And (second) removed it.
    And also did a reboot. But always the same result, no icon in the bar
    What to do, any hints?

    I Safari I see the icon but there also I have still the problem with the auto-fill
    Here are the saved formular data in the extension:

    And when I click "Go" it fills in the wrong fields, probably because the last pw does not have a label like "koop-form:user..."

    Do I have to create the whole items new (i.e delete them first and then create new)
    Or can I somehow edit this section?

  • ag_anaag_ana

    Team Member

    @falo_user:

    But I do not see the 1PW icon in the browser top bar.

    Can you please try these instructions and see if they help?

    If you don’t see the 1Password icon in your browser

  • Hi I also cannot get this site to work.

    I am on Windows 10 and have 1PW X 1.21.0 installed in Firefox 80.0.1.

    I enter the details in the login form and if I click in either the Verfügername or PIN fields the "Save in 1Password" button appears.

    I click on that I get the dialog where I enter the Title and choose where to save it.

    A popup informs me it was saved.

    When I examine that saved entry in 1Password what I entered in the Verfügername field is saved as the username and what I entered in PIN is saved as the password.

    If I show Web Form Details I can see the Verfügername/username is associated with "koop-form:userName" and the password with "koop-form:password". Examining the source of the web page I can see the form id for Verfügernummer is "koop-form:userId" but is missing in 1PW.

    Let me know how and if I can help to figure this out.

  • ag_yaronag_yaron

    Team Member

    Hey @ja1pwu ,

    When I save a completely new login on the page, it creates a proper login that autofills correctly for me. Check it out: https://recordit.co/VgLvakvUva
    Can you please delete your current login from 1Password, then repeat the steps in my video and see if it works?

  • Hi @ag_yaron

    Thank you so much for the quick reply and the helpful screen recording!
    That does indeed work in the desktop browser.
    I must have gotten things mixed up when testing.

    Once I've saved that there I was hoping this would also work in Chrome on Android 11 with latest 1PW (installed today).

    After I tap in "Verfügername" and choose the Hellobank login from 1PW it only fills in those two fields you can see in the screenshot below but also those two must be filled with the incorrect data because if I then manually fill in "Verfügernummer" the login fails.

    kind regards,
    J

  • ag_yaronag_yaron

    Team Member

    I'm glad to hear things are working well on your computer now :)

    1Password X contains some fixes that the Android app does not when it comes to autofilling enhancements, but it will get it eventually. We're currently working on unifying all of our apps' code base to a single one, so eventually all apps will receive the same updates and enhancements simultaneously.

    In the meantime, my best suggestion would be to save a new login for that website on your Android phone and use it (then manually type in whatever's missing when you autofill), and use the one we previously saved here only when you're on your PC.
    Sorry for the inconvenience there.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file