Unable to establish connection with a 1Password desktop app

The error came up recently

1Password Version: 7.5.BETA-0 (70500000)
Extension Version: 1.19.0
OS Version: 10.15.4
Sync Type: Not Provided
Referrer: forum-search:Unable to establish connection with a 1Password desktop app


  • I have the same issue with the same OS, software, and extension version. I upgraded to 1PasswordX beta (both app and extension) in order to get the app<-->extension communication, including touch id functionality.

  • (With Chrome version Version 81.0.4044.92)

  • dickwyndickwyn
    edited April 2020

    @chrisroat Yes, I have installed the latest beta version of the Mac app and Chrome extension

    v1.19.0 and v7.5.BETA-0 is the latest versions but i'm still unable to get touch id to work on the chrome extension

  • dickwyndickwyn
    edited April 2020

    oh, I just saw the release page and the latest release for the chrome extension is v1.19.1 but in the Chrome store, there's only v1.19.0.

    And when I click Check for Updates on the extension, there's a notification there telling me that I have the latest version installed already. How did you get version 1.19.1?


  • I have the same version as you, as mentioned in my post.

  • FYI. I quit Chrome and 1Password desktop, then restarted both. The communication now seems to be working - unlocking the desktop app unlocks the extension, and I can use fingerprint id with the extension. @dickwyn

  • Hmm, I tried that and didn't work. Also re-started my machine and still having the same error @chrisroat

  • kaitlynkaitlyn

    Team Member

    Hey there @dickwyn! Sorry to hear you're having some trouble with Desktop App Integration. I'm here to help. :)

    Can you please hold down the option key and click the 1Password icon in the right side of your macOS menu bar? Then click on Quit 1Password Completely. Additionally, right click on the Chrome icon in your dock and select Quit. Go ahead and reopen both 1Password and Chrome once that's done.

    If you're still seeing the same error on the 1Password X settings page, we'll want to see a copy of your 1Password X log as well as a diagnostics report from your computer to make sure everything's set up properly. The latter can only be emailed in, though. If you're up for it, please send an email to [email protected], and mention a link to this post as well as your forum username. You can find instructions on how to obtain both your diagnostics report and your 1Password X log below.

    1Password X Log
    Diagnostics Report

    Let me know once you've sent the email, and I'll take a look!

  • ag_anaag_ana

    Team Member


    Got them! And I see that my colleague Nhat has already been helping you over there, so I will let you continue the conversation via email :+1:

    ref: GNZ-43267-324

  • I'm getting the same "Unable to establish connection" error on the chrome extension. I have all the latest betas (see below). let me know what I should try to fix/help debug!

    • OS X: 10.15.4
    • chrome: Version 83.0.4103.61 (Official Build) (64-bit)
    • 1PW desktop: 1Password 7, Version 7.6.BETA-0 (70600000)
    • 1PW chrome: 1Password X, Version 1.20.0
  • ag_anaag_ana

    Team Member


    Can you please try the suggestions posted by Kaitlyn, and see if they help? Should you still see the same thing, please send us the logs so we can take a look at them (you will find instructions for that in Kaitlyn's post too :) )

  • that worked... thank you!

  • ag_tommyag_tommy

    Team Member

    On behalf of Ana, you're welcome, and thanks for letting us know Kaitlyn's instructions were able to help you.

This discussion has been closed.