I want to use fingerprint to unlock chrome extension

Hi guys,

Hoping you can clarify some thing for me.

It all started because 1Password-X Chrome extension wasn't using my fingerprint to authenticate. Until now, each time I ht crtrl-x to unlock 1P-X, it prompted me for my password, not fingerprint. Opening the app locally, does prompt for my password. So after reading the blog, I think it said that only the 1P-X beta supported fingerprint.

So I removed my current 1P-X extension and installed the beta. After the last update was released I get this message from the extension.

Am I missing something?

Thanks in advance,
Roger


1Password Version: 7 Version 7.5.BETA-1 (70500001)
Extension Version: 1.19.1
OS Version: OS X 10.15.4
Sync Type: Not Provided

Comments

  • Hi, with the new update released the integration between chrome and 1password app was disabled? This feature is going to be in future versions?

  • ag_anaag_ana

    Team Member

    Hi @rogerrayner! Welcome to the forum!

    I have merged both your comments in the same discussion so we have everything in one place ;)

    Can you please try quitting 1Password completely (right-click on 1Password mini in the menu bar at the top right of your screen > Quit 1Password Completely), and also right click on the Chrome icon in your dock and select Quit? Then relaunch both 1Password and Chome and see if that helps.

    If you're still seeing the same error on the 1Password X settings page, we'll want to see a copy of your 1Password X log as well as a diagnostics report from your computer to make sure everything's set up properly. The latter can only be emailed in, though. If you're up for it, please send an email to [email protected], and mention a link to this post as well as your forum username. You can find instructions on how to obtain both your diagnostics report and your 1Password X log below.

    1Password X Log
    Diagnostics Report

    You can email the logs to us at [email protected] After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • @all - the 1.19.2 update has been released few minutes ago. It works like a charm.

  • ag_anaag_ana

    Team Member

    Thank you for the update :+1::)

  • @wizard86pz when I click to update my 1password x it appears a message that I have the latest, but I have the 1.19.1 installed.

    @ag_ana I have to do something different to update?

  • It's about Google Chrome extension platform, I'm in Europe, and the update is spreading around the world, let's wait at least 24h for you.

  • Ok... thank you for all information.

  • ag_anaag_ana

    Team Member

    @rogerrayner:

    Indeed, you should just wait a bit longer, nothing else for you to do at the moment :)

  • Hi, my extension updated e everything is working like a charm (as @wizard86pz said hahahahaha). Tks for the help guys.

  • ag_tommyag_tommy

    Team Member

    I am glad to hear the release is working its way through the store. Even better things are working for you. Let us know if things change.

  • Hi. I have the following dmg installed on BigSur. (apple M1 chip). 1Password 7. Version 7.7 (70700015)
    Chrome extension is installed.
    1PW application (ie desktop app) prompts for fingerprint.
    Extension does not.
    I've tried disabling/ re-enabling touch ID.
    I've removed/ reinstalled the extension.
    Suggestions? Help!

  • ag_tommyag_tommy

    Team Member

    @paulr540

    Which version of our extension are you using our companion app extension or 1Password X?

  • 1 password X is the one I downloaded. should I be using another?

  • ag_tommyag_tommy

    Team Member
    edited January 15

    @paulr540

    1Password X's Touch ID feature has temporarily been removed. An announcement is posted in our forum from one of our founders. It includes details on what the future holds. https://1password.community/discussion/115228/temporarily-removing-desktop-app-integration/p1

    If Touch ID is needed you could optionally switch to our companion app extension until the feature is brought back to 1Password X.

    1. Disable 1Password X in the Chrome extension settings. No need to remove it.
    2. Download and install the companion app extension.

    --

    Due to the extensions' differences, you may first need to completely quit your browser and 1Password for communication to work properly.

    1. Quit your browser.
    2. Look for our helper in the menu bar near the WiFi indicator and the clock. Right-click on the helper and select quit 1Password completely. Wait a few seconds and then open 1Password from the Dock or the Applications folder.

    Please let us know if you have additional questions. We would be more than happy to assist you.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file