The Mac application will not stop asking me to add 1Password extension to Firefox

I have already added the extension to Firefox, but if I have Firefox open the 1Password Mac app will open to a screen that reads "Install the 1Password extension..." with a link to "Add 1Password to Firefox." This is frustrating because there is no way to close this notification, I can only use the search function.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • BenBen AWS Team

    Team Member
    edited April 30

    Hi @passquests

    I'm sorry to hear about the trouble. We currently have two Firefox extensions: 1Password X and 1Password (desktop app required). Only the latter integrates with the 1Password for Mac app, at the moment. We do have integration for 1Password X in beta, if you want to try that:

    Introducing Desktop App Integration for Mac! 🎉 — 1Password Forum

    Alternatively you'd want to uninstall 1Password X if installed and instead install the 1Password (desktop app required) extension. I hope that helps. Should you have any other questions or concerns, please feel free to ask.

    Ben

  • Hi @Ben ,
    I'm having the same issue but your response doesn't address the annoyance @passquests is alluding to; I use 1Password X in Firefox and would rather use that than the separate Firefox Extension. Here's the problem: whenever I have the Firefox window open and want to use the Mini Desktop App for a quick copy/paste or whatever reason, the Mini Desktop App will inevitably skip opening in my Favorites (which I have designated in "Preferences" for the Mini Desktop App to open with) but instead display in an advertisement/reminder asking me to "Add 1Password to Firefox." (See attached photo showing the ad and also my preferences for Mini.) This is annoying because it requires me to have to take 3 extra steps to get around which contradicts why I use the Mini Desktop App in the first place.

    Since I do not want to use the Firefox Extension and would rather use 1Password X for Firefox, is there a way to disable this advertisement/reminder?

  • BenBen AWS Team

    Team Member

    Since I do not want to use the Firefox Extension and would rather use 1Password X for Firefox, is there a way to disable this advertisement/reminder?

    There is not; sorry. It is likely that once we have Desktop App Integration built-into 1Password X that feature will address the situation, but until then 1Password mini doesn't know that you have 1Password X installed in Firefox and so it is going to continue to suggest that you install the extension it does know how to talk to.

    Ben

  • Darn. Glad to have an answer, though. Thanks, @Ben .

  • BenBen AWS Team

    Team Member

    You're welcome. :)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file