Accidental white space at end of password can't be removed?

Attempting to generate a password for this site: https://app.raizinvest.com.au/login and after generating the password in 1passwordX I saved it in a draft email. Then I logged on using the old password but accidentally 'lost' the copied password so went to the saved draft and copied it from there.
However I accidentally 'copied' some white space after the end of the password.

Now when I auto fill the login page, the LOGIN button at the bottom is greyed out. If I put the cursor at the end of the password dots and hit delete to remove the white space it lets me logon. I then went into 1password to make sure there was no white space at the end of the saved password and there appears to be none. However every time I autofill the login page, I get the password+'white space' and have to manually delete the white space before I can login. I have generated new passwords but the same thing now seems to occur with the new passwords although I took care to NOT include any 'white spaces'. Can anyone advise how to get rid of tjis? I have even deleted the Raiz entry in 1password and recreated it but it still occurs.
Thanks, Bernie.


1Password Version: Not Provided
Extension Version: 1.19.1
OS Version: Win 10
Sync Type: Not Provided

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @bernie01

    I'm trying to test that URL you provided here, but nothing seems to make that Login button active. I even disabled the 1Password extension and am manually writing an email and a password in the fields, but the Login button remains disabled. Are you able to get it enabled at all?

  • Thanks Yaron, yes I am able to get it enabled and then login. It's may be a little different to what I posted above, as I was focused on the fact that I thought I had inadvertently added white space to the end of the saved password which may not be correct. This is what happens: I autofill the userid/password from 1passwordX. The login button is not active. Then I place the cursor at the end of the password string and I was previously hitting the delete button which made the login active and I could get in. Now I've discovered that if I hit enter instead of delete, the login button is active and then enter again I get logged in again. I've generated a new password (a few times) and it still behaves the same way so I don't know if the original white space added still persists or not but I doubt it.

  • ag_yaronag_yaron

    Team Member

    Thanks for the followup @bernie01 .

    I simply can't get the Login button to activate, so I assume they're either blocking me based on my location, or that they actually check if the email exist in their system before allowing a login attempt.

    Either way, I checked the password field and at no point did I see a blank space at the end. The password is being autofilled correctly and I'm certain it is not a part of the issue. The issue here seems to be their strange script of disabling/enabling that Login button.

    Normally, in most websites that use such a script, the Login button will wait for a keyboard input in order to get enabled, and since 1Password does not provide such a keyboard input, but instead injects the password directly into the field, the button remains disabled even after autofilling. However, clicking on the password field and adding/deleting a single character will enable that button and allow you to log in.

    It does seem like this is the case on that particular website, does it not?

  • Hi Yaron,
    yes I agree, and I can live with this. Perhaps I will encounter other websites that have the same problem, which will help me to remember to add/delete a character. Many thanks for your assistance.
    Regards, Bernie.

  • ag_yaronag_yaron

    Team Member

    Glad I was able to help.
    Perhaps one day we'll find a way to get around such pesky login forms (if that is even possible), but until then my best suggestion would be to send an email to the website's support and let them know how their login form prevents autofilling, which is bad for the user's experience and security.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file