Changing email on 1P account -> iOS re-login quirk

edited July 10 in iOS


First off, this is not a huge deal and I'm not locked out or anything, so we're all good there. I'm just wondering if this is a known issue.

My setup is two mac computers with the full desktop program, and 1Password X in Firefox on both. I also have an iPhone X with the 1Password app. I'm running the latest stable versions of the operating systems and the 1Password apps on both computers and my phone. Everything has been fine, but I ran into a weird issue today when I changed the email address on my 1Password account. It's a Families account and I'm the owner, if that makes a difference, but I don't think it does. It is relevant to this issue, though, that I have 2FA setup on my account with a Yubikey, which is NFC compatible, and a TOTP generator (Google Auth) on my cell.

I logged in to the website ( and changed my email address in my profile there, no big deal. Immediately after I changed the password, my desktop 1Password program (which I was already logged in to) prompted me to re-log in. That went fine, and it prompted for my Yubikey, and all was well. I knew my phone would be next (other computer at home will be later) so I unlocked the phone and opened the 1Password app. It immediately prompted me to login again, as expected, but it kept rejecting my master password, which I 100% know I was typing in correctly. It already had my account info (the new email, and the secret key) filled in but I double-checked those as well. Eventually I got frustrated and clicked "skip for now" or however it was worded, and signed completely out of the 1Password app.

I opened the app back up to log into my account, and it still remembered my (new) email and my secret key. I put in my master password, and it accepted it this time and prompted for my 2FA. I could choose between methods, so I selected NFC and scanned my Yubikey. However, while I was scanning my Yubikey (which accepted just fine), an error message popped up behind the Yubikey screen saying it could not log me in and to try again. I don't remember the exact wording, but I believe it was similar to the message I was getting when it kept rejecting my master password before I did the complete sign-out.

I tried this a few more times, and the same thing happened: log in, select saved account, enter master password, scan NFC, and the error was behind the Yubikey screen again. Eventually I chose the TOTP option for my 2FA, and that worked fine and I am now logged in. But does anyone know why this would happen?

Sorry for the wall of text, but I wanted to be detailed in case this is an actual issue that devs need to be made aware of. I don't think I did anything incorrectly, and I doubt it is anything specific to my account. But I just wanted to put this out there.

Thanks for any feedback!

edit: fixed a typo. my bad.

1Password Version: 7.6
Extension Version: Not Provided
OS Version: iOS 13.5.1
Sync Type: 1Password Membership


  • blzblz
    edited July 10

    I should also add that I'm certainly willing to log out on my phone and try it again, if anyone from 1Password sees this and would like me to try it. But I want to wait until I get home later so I can get my other computer logged in. I don't foresee any problems with either computer, but just in case. :)

  • BenBen AWS Team

    Team Member

    Hey @blz

    Thank you for reporting this. It sounds like reproducing this would hinge on having a Yubikey that is compatible with 1Password for iOS. Unfortunately I don't have one. I'm trying to track down who on the team does that could test this for us. Once we have that we should have a good start on tracking this down. At this point I don't think we'll need you to go through the process again, but we'll follow up here if that would indeed be helpful. :)



  • blzblz

    Sounds good. Mine is the Yubikey 5 NFC, in case that matters. Thanks again.

  • BenBen AWS Team

    Team Member

    Sounds good; thanks!


  • BenBen AWS Team

    Team Member


    Our QA team took a look at this and believe they've identified a bug in 1Password for iOS. We'll be working with our development team to get this sorted out for a future update. Thank you for taking the time to report the issue!


    ref: dev/apple/issues#4875

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file