Favorites do not always work

I have set up a few favorites for websites for which I have more than one login. Mostly for Banks and Apple ID.
When logging in with Command Backslash, often but not always, the favorite is not the correct login, a secondary login for the same website logs in. When subsequently I chose the 1PW menu item on the browser on in my menu, the correct one is displayed and I press autofill and I get the correct login.
This seems to be a bug


1Password Version: 7.6
Extension Version: 7.6
OS Version: 10.14.6
Sync Type: ??
Referrer: forum-search:favorites don't work

Comments

  • ag_anaag_ana

    Team Member

    Hi @tommy!

    Are you able to consistently reproduce this on demand? If you can, please share the step by step instructions and we will be happy to test them here too :+1:

  • tommytommy Junior Member

    Nello @ag_ana
    Go to web page: f e Apple ID. Press command backslash to unlock 1pw. Again press command backslash. Instead of filling the favorite credentials (the one with the star), the second credentials are filled (the one directly below the favorite).
    This does not always happen. Perhaps it only happens when 1pw is locked.

  • ag_anaag_ana

    Team Member

    @tommy:

    Thank you! I have tested this both with 1Password locked and unlocked, but I could not manage to fill the wrong credentials: when I try to fill credentials on the page, I always get the list of logins for the website, since there is more than one for this URL in this case. And even selecting one or the other always fills the right one.

    I will keep an eye out in case we get similar reports however :+1:

  • tommytommy Junior Member
    edited August 8

    @ag_ana You mean I have a gremlin? If I select the credentials, I have no problem. If I type command backslash twice, once to unlock, the next to fill credentials in, I get the wrong ones. Otherwise everything works. If I can see the login list I have no problem. This behavior is irritating
    Thanks any way

  • ag_anaag_ana

    Team Member

    @tommy:

    Possibly a gremlin, yes :D This is the only report that we received on this so far if I am not mistaken, and I believe we would have many many more if this happened to everyone.

    I wonder if refreshing things would help you. Can you please try quitting 1Password completely (right-click on 1Password mini in the menu bar at the top right of your screen > Quit 1Password Completely), and then relaunch 1Password? Do you see the same behavior now?

  • tommytommy Junior Member

    I'll try that. I shut down every evening so I don't think it will make a difference

  • ag_anaag_ana

    Team Member

    Understood @tommy, let us know what you find out :+1:

  • tommytommy Junior Member

    I have my apple ID and my wife's in 1pw. Mine is starred. Invariably, like clockwork, when enter login with Command \ I get my wife's. If I press the 1pw icon in my browser, the correct one is selected.
    This is maddening

  • ag_michaelcag_michaelc

    Team Member

    Hey @tommy. Do both Login items in 1Password have the same exact website, and does it match the website you're on exactly? The behavior we should expect to see is that 1Password mini opens and lets you choose which login to fill, since there are multiple matches. Favoriting a login does not mean that it becomes the default for AutoFill.

  • tommytommy Junior Member

    Hi @ag_michaelc Interesting. The website is the Apple ID - so yes it is the same. 1PW mini does let me chose. I thought command backslash would fill the website - including the favorite. It does happen on other websites too. So in essence behaviour is normal and I am expecting something that shouldn't happen? Why is command backslash so good in choosing the wrong login and password?
    That didn't come up earlier in this string.

  • ag_michaelcag_michaelc

    Team Member

    Hey @tommy. Command-\ will fill your login when there's one exact match, but otherwise it should bring up 1Password mini. I know that the logins are both for your Apple IDs, but are the actual URLs the exact same? For example, my Apple ID's URL is https://appleid.apple.com.

  • tommytommy Junior Member

    Hi @ag_michaelc Interesting. The website is the Apple ID - so yes it is the same. My procedure is to press Comand \ to unlock 1pw and if is unlocked, that command fills the login and password, often the wrong one if there is more than one login. If I press the 1pw icon in the browser or in the menu bar will bring up 1Pw mini and I can chose autofil. The favorite is on top.
    I do have logins for which the URL is the same for more than one login. In those other cases 1pw opens the mini with Command \
    In conclusion it is only consistent insofar as several URLs with more than one login do not open 1pw but types the wrong login.

  • ag_anaag_ana

    Team Member

    @tommy:

    My procedure is to press Comand \ to unlock 1pw and if is unlocked, that command fills the login and password, often the wrong one if there is more than one login.

    This is the interesting part: when there is more than one login for the same website, 1Password does not fill a login automatically. Instead, it should open 1Password mini and show you the list of logins for that website. Only when you select one of them, will 1Password fill those credentials on the web page.

  • tommytommy Junior Member
    edited October 2

    @ag_ana

    I' assure you command\ fills credentials most of the time when there are two alternatives for the same URL
    I just wanted to log in to apple id. I pressed command\ to unlock. As soon as I unlocked with touch id, the wrong credential was put into the username field. To coreect I have to press on the 1PW icon and open 1pw mini and the correct credentials appear on top

    Quite frustrating

  • tommytommy Junior Member
    edited October 2

    x

  • ag_yaronag_yaron

    Team Member

    Hey @tommy ,

    Thanks for clarifying the situation. From what you describe so far, something is definitely a bit off since 1Password should not autofill anything when you press CMD-\ when there is more than one login entry for a specific website.

    I'd like you to try and create new logins for Apple ID's website and see if you are still able to reproduce the issue. Please try this:
    1. Go to the Apple ID login page in your browser.
    2. Manually save your login credentials there in 1Password as a completely new login entry using this method: https://support.1password.com/save-login-manually/
    3. Repeat step 2 for your wife's login credentials and create a new login entry for her as well.
    4. Delete the old login entries you have from 1Password.
    5. Mark your new login entry as a favorite and see if you can reproduce the issue by locking 1Password and trying to autofill with CMD-.

    Does the issue still occur with the new set of login entries?

  • tommytommy Junior Member

    @ag_yaron Hi
    Sorry for the delay. That seemed to work. However I had to delete the original items before it worked
    I tried it on Firefox and Opera and it worked.
    thank you

  • ag_anaag_ana

    Team Member

    On behalf of ag_yaron, you are welcome @tommy! I am glad to hear that things are working again :)

    If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file