Submitting Filled Login Causes Page to Reload

After using the browser extension to fill a login, I press Return to submit the login page. On some sites, this causes the page to reload (?) without the login information present, so I have to fill the login a second time. On this second attempt, when I press Return, the login is successful. It doesn't happen on every site, and on the sites where it does happen, it doesn't happen every time. I can't find a pattern to it.

I know this is happening in Chrome 84.0.4147.135, and I believe I've seen it happen in Safari 13.1.2 as well. One site it happens on is https://account.authorize.net/

Has anyone else experienced this inconsistent issue?


1Password Version: 7.6
Extension Version: 4.7.5.90
OS Version: macOS 10.15.6
Sync Type: 1Password Subscription

Comments

  • ag_anaag_ana

    Team Member

    Hi @ilias! Welcome to the forum!

    I have tested the website you mentioned but I could not reproduce the issue you are describing. Do you see the same behavior if you copy and paste your credentials on the website, instead of using the browser extension to fill them? I wonder if the website is doing something to prevent password managers working on that page.

  • iliasilias Junior Member

    I believe I have used copy and paste to log into the site without having to do it twice, but I haven't verified it (just recollection). It's been a difficult thing to track because the behavior I described in the OP doesn't happen every time—maybe 20% of the time. Now that I'm consciously thinking and writing about it, I can make a note of other sites where the behavior occurs and add them to this thread. I don't know if this is related, but I've also noticed that when I use the extension to Open and Fill a login (the login page isn't already open), there is occasionally a long delay before the login credentials appear. I'll use Open and Fill, a new browser tab opens, the page loads, and sometimes 5 or more seconds go by before the login credentials appear. Sometimes, they don't appear at all, and I have to invoke the Fill a 2nd time. This is another behavior that's inconsistent and difficult to track.

  • ag_anaag_ana

    Team Member

    @ilias:

    I should also say that I am currently using the latest 1Password 7.7 beta, so it's possible that the difference of behavior is because of that. But if you do find a way to consistently reproduce these, by all means let us know and we will be happy to test your instructions :+1:

  • iliasilias Junior Member

    I finally figured this out. It's not a 1Password issue at all. In Chrome, if you invoke Open and Fill while the Address Bar has focus in a new tab, the Address Bar retains focus even after the password fill in whatever login was just invoked. What that meant for me was when I was pressing Return to submit the login, I was simply re-submitting the URL from the Address Bar, effectively reloading the page and not logging in.

    If a tab in Chrome has been used—if you've navigated away from the new tab in any way—you won't see this behavior. In this 2nd scenario, if the Address Bar has focus while invoking Open and Fill, the focus will move from the Address Bar to the login form, making a Return press log you in instead of "reloading" the page. Seems to be a quirk of how Chrome handles new tabs vs "old" tabs; I never connected this relationship before.

    Incidentally, Safari doesn't not behave this way, which is why I've never seen it in that browser.

  • ag_yaronag_yaron

    Team Member

    Hey @ilias ,

    Wow, great catch! Pretty funny edge case but I'm really glad you figured this out. We'll take note of it in case someone else describes a similar issue, hopefully it will help other users as well :)

    Thanks for sharing your findings! Much appreciated.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file