How can I get autofill to check an "agree to the terms and conditions" box?

On this login page:

I'd like autofill in the Chrome extension to check the "Agree to our terms and conditions" checkbox. Currently it only fills in username and password. I have to use this multiple times per day for work. How might I set autofill to check that box?

Thanks!


1Password Version: 6.8.9
Extension Version: 4.7.5.90
OS Version: Mac OS 10.14.6
Sync Type: icloud

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @mrengy ,

    You can manually add that checkbox to the login item in 1Password. Here's how:

    1. Open and unlock the 1Password desktop app.
    2. Find the login for this website, select it and click on "Edit" to enter edit mode.
    3. Click the "View saved form details" at the bottom, which will reveal the fields that were recorded from the page.
    4. Under the username and password fields, select the next empty field and name it "tandc" (all lowercase), then change its type on the right side from "Text" to "Checkbox" and check that checkbox.
    5. Click on "Save", close 1Password and test autofilling on that website.

    Here's a screenshot of what it should look like when you edit:

  • mrengymrengy
    edited September 3

    Thanks for the clear instructions.

    However, I tried, but it didn't work.

    When I first came to edit the web form details, there were some other fields in there that were set from the registration page, and it also had "t-and-c" as a checkbox:

    [Screenshot removed]

    I edited it to delete the other fields and change the checkbox to "tandc", like so:

    [Screenshot removed]

    Then saved and tried to autofill again, and it still only filled in username and password but did not check the box. I double checked that the label matched the "name" attribute of the terms and conditions checkbox, which is the same as the ID. Really puzzling.

    [Screen recording removed]

  • ag_yaronag_yaron

    Team Member

    Thanks for the additional info @mrengy .
    I edited your comment and removed your screenshots and recording because they contained some real data, and since this is a public forum it is not the best idea to publish it uncensored :)

    Testing it again with 1Password 7.6, it did autofill the checkbox for me once more, so now we just need to compare our setups.
    I tested it on Mac OS 10.14.6 with Safari 13.1.2.

    I just noticed in your initial message that you are using 1Password 6.8. Is that correct? If so that might be a big reason why this is not working for you.

  • Okay, thanks. Well, all the passwords in the screenshots were obscured as bullets, but I suppose that doesn’t hurt.

    Yes, I’m using 1Password 6. Will consider upgrading...

  • ag_yaronag_yaron

    Team Member

    I highly recommend upgrading, not because I work here but because:

    • It is strongly recommended keeping up to date with security software in general.
    • There are a lot of improvements in 1Password 7, including autofilling ones.
    • 1Password 6 hasn't been updated or maintained in over two years now.

    If you have any questions regarding upgrading, feel free to email them to [email protected] and our team will gladly help.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file