enabling safari extension not cooperating

Hi,
I've been struggling with the browser extensions for 1P for months on one machine in particular. Safari is effectively unusable as it refuses to enable the extension (believe me I've tried everything).

Uninstalling and reinstalling everything multiple times including all the extensions for other browsers doesn't make a difference.
Also when 1P is installed Chrome often crashes on the 1st and/or 2nd launch and 1password itself frequently crashes after booting. I recently installed the latest chrome Beta (replacing a normal release) and the crashing stopped but when I un/re-installed 1P to try to fix the Safari extension it started crashing again

1Password is a vital piece of software for me and I'm happy to hold my hands up if I've messed anything up but I'm stumped what to do as it used to be so stable and reliable. The laptop I'm struggling with is a recent clean install upgrade from macOs 10.14 so it's doubly puzzling why things misbehave, prior to the upgrade 1P was unresponsive but generally usable - nowadays I must work through the main 1P app to copy/paste stuff into Safari.

Any ideas, bearing in mind I've tried everything in the FAQs that I can see?

Emyr

1Password 7.6 (70600006)
macOs 10.15.4
Safari 13.1
Chrome 85.0.4183.83 (1P extension 4.7.5.90)
Firefox 80.0.1

Comments

  • ag_anaag_ana

    Team Member

    Hi @emyr! Welcome to the forum!

    We will be happy to take a closer look at your 1Password configuration and see if we spot anything weird :+1: To do this, I would like to ask you to generate a diagnostics report from your Mac and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Hi!

    Thanks a lot. The ticket number is [#GUK-41898-974]

    Have a great weekend.

    Emyr

  • ag_anaag_ana

    Team Member

    @emyr:

    Thank you! I confirm that I have managed to locate your diagnostics report in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: GUK-41898-974

  • emyremyr
    edited September 25

    Hi again, After following your support advice and trying everything I can think of I'm still in the same position. However, I recently updated my OS to x10.15.6 and the new Safari 14.0 now gives a message when I try to enable the extension (see screenshot). Clicking "Learn more" brings me to the apple help documents you've already directed me to and although I tried everything again it still won't enable.

  • BenBen AWS Team

    Team Member

    Hi @emyr

    I wish we had a way to know what it is that is covering your screen, preventing Safari extensions from being enabled. Unfortunately there is no way for us to know that. The best I could suggest here would be to reach out to Apple for further assistance. They may have a way of determining what is running on your system that is interfering with Safari.

    I apologize that we don't have a better way to help more directly here.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file