After updating to the new extension in Safari 14, 1Password no longer works

2»

Comments

  • BenBen AWS Team

    Team Member

    @macthecaptain

    Could you please elaborate on how Intego plays into this? Please open Finder and then navigate to the Applications folder. Do you see more than one copy of 1Password there?

    Ben

  • I have macOS 10.15.6, Safari 14.0, and 1Password7 7.6 Something changed and I can no longer 'fill' the website with user and password. I have to copy and paste both. I have 'shutdown', reinstalled the Safari 1Password extension, 'quit completely' and restarted, but I am doing something incorrectly or the 1Password is not working correctly. I am not a real skilled techno guy, but would appreciate some help, please.

    Red faced reply.... Intego should have been 1Password
    I look in Finder and see only 1Password7.app, and a 1Password7.app.zip
    Would moving from license to subscription Mac all of this easier? How could I do that as a customer of several years?
    I don't want to have it be this difficult for my partner or heirs to unscramble.

  • BenBen AWS Team

    Team Member

    Red faced reply.... Intego should have been 1Password

    Gotcha! No worries. Just wanted to make sure there wasn't some unknown complicating factor here.

    I look in Finder and see only 1Password7.app, and a 1Password7.app.zip

    Okay, it doesn't seem multiple copies of the app is the difficulty then. Have you tried rebooting the Mac?

    Would moving from license to subscription Mac all of this easier? How could I do that as a customer of several years?

    That would be the recommended way forward. We have a guide to help customers transition available here:

    Move your existing 1Password data to a 1Password account

    I hope that helps!

    Ben

  • I'm having the same issue. I recently switched from Brave back to Safari but none of my extensions work.

    1Password 7 (version 7.6)
    Mac App Store
    Safari (version 14.0)
    MacBook Pro 13" (macOS Catalina 10.15.6)

    Any suggestions for what I can do?

    Thanks
    Will

  • BenBen AWS Team

    Team Member

    Hi @Monoboy

    Please try these instructions:

    1. Quit Safari
    2. Open and then quit 1Password completely — ⌘⌥⌃Q (Command Option Control Q)
    3. Drag 1Password to the Trash, but DO NOT use a "cleaner" app to remove 1Password if you have one (MacKeeper, CleanMyMac, AppZapper, etc)
    4. Empty the Trash
    5. Restart your Mac
    6. Install 1Password from our website: Download for Mac
    7. Open 1Password
    8. Make sure the extension is shown and enabled in Safari under Preferences > Extensions (do not click "More Extensions")
    9. Verify that you're able to use the extension to fill logins

    Ben

  • MonoboyMonoboy
    edited October 5

    Thanks Ben,

    I can't use any extensions with Safari 14.0.

    I spent an hour with Apple support who suggested creating a new user account and transferring to that. Which I did, and I can now see and use extensions in Safari 14.0. Unfortunately, 1Password launches but doesn't work. It popups up a collapsed modal window with nothing in it, and all the 1Password menu items are greyed out. Including the 'Sign in to my account' under the Account menu. Clicking the 1Password icon in the Safari menu bar does nothing. A conflict somewhere.

    I'm guessing it has something to do with my Keychain, which repeatedly asks for a login for Adobe Create Suite applications on startup.

    It won't accept my Keychain password, nor can I change it. So I'm totally snookered.

    I've reverted back to using Brave on my old user account. It's not worth the hassle of a completely new setup.

    But thanks for the reply anyway.

    Will

  • BenBen AWS Team

    Team Member

    Hi @Monoboy

    I'm sorry to hear you're having such difficulties with your Mac. Indeed it does sound like something is awry with your macOS user account (and perhaps even deeper than that). I'm glad Brave is working for you for now. If you decide you'd like to troubleshoot further please let us know, however I'm afraid it sounds like that may require major surgery. Going forward when you get a new Mac I would not recommend using Migration Assistant or Time Machine to move your data to it, as you'll likely move whatever problems exist with the current Mac over to the new machine by doing so.

    Ben

  • Thanks for the tip Ben. Yes, a clean install and setup is probably needed. I think I'll hold out until I can get my hands on a new machine.

  • BenBen AWS Team

    Team Member

    Sounds like a plan. :+1::)

    Ben

  • jaylindelljaylindell Junior Member

    I am using 1Password 7 Version 7.7.BETA-10 (70700010). After the Safari 14 update, clicking on 1P in Safari or the menu bar brings up the correct site, but does not auto-fill. Some additional insight here might be the attached screen, which I get when I disable the extension and then re-enable:

    I have an ad blocker extension installed but not activated:

    Any ideas/help would be appreciated.

    Thanks!

  • BenBen AWS Team

    Team Member

    Hi @jaylindell

    It appears from the screenshot the extension is enabled as expected. What steps are you taking to attempt to fill? Please let me know. :)

    Ben

  • jaylindelljaylindell Junior Member

    Hi Ben. Yes, it is enabled. I am invoking the 1P Mini key combo. It is the same result as clicking the 1P icon on the Safari toolbar or menu bar. In all cases, the correct web site password is displayed. There’s the usual Auto-fill button. Usually hitting enter on the keyboard or pressing the button will auto-fill the user name and password. But that is no longer working.

  • BenBen AWS Team

    Team Member

    @jaylindell

    I have to admit I'm scratching my head a bit on this one. I'd like to have our extensions team take another look to get a fresh perspective. To facilitate that I'd like to ask you to create a diagnostics report from your Mac:

    Sending Diagnostics Reports (Mac)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://1password.community/discussion/comment/575146/#Comment_575146
    • Your forum username: jaylindell

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that it is routed to our extension folks.

    Ben

  • jaylindelljaylindell Junior Member

    I've sent it, Ben. No BitBot reply yet. Will keep an eye out and post the support ID number here if/when it comes

    Thanks for your support :-)

  • ag_tommyag_tommy

    Team Member

    @jaylindell

    I was able to locate your report. Someone will get back to you as soon as possible.

    ref: BAM-97394-441

  • jaylindelljaylindell Junior Member

    Thanks! If I had just waited three more minutes...good bot, good bot. :-)

  • BenBen AWS Team

    Team Member

    Thanks @jaylindell ;)

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file