BUG: Logins with Two Websites and One-Time Password Have Display/Scrolling Issues

Hello. Searched the forums and couldn't see this issue reported, so. What I'm seeing is on iOS, for Login entries that have two websites and a one-time password defined, when I open the Login entry in the iOS client it doesn't scroll smoothly (like say I'm trying to scroll down to see the OTP value). The scrolling stutters, HARD, and I can actually see the scrollbar on the right going all herky-jerky too, spastically growing longer and shorter a bunch of times really quickly, like the whole app is totally confused as to how long the entry actually is.

What's more, once I get the OTP value into view, it's not ticking. It's frozen. If I scroll up and down enough, particularly if I get to the bottom of the entry and then scroll back to the top, eventually the stuttering goes away and it'll scroll smoothly again. The OTP also starts ticking again. Note: the OTP doesn't actually stop, not internally I mean. It's just the display of it. When it begins ticking again it leaps to whatever it currently should be showing, no delays, not out of sync with other devices. Like it might be stuck on 27 seconds and once it starts going again it might leap to 5 seconds and then continue on normally.

Even if I get the entry scrolling smoothly, I can hit Back and go back to the full Login list then view the particular entry again, and the stuttering scroll will be there again.

I did some troubleshooting of it, and I can fairly confidently say the bug is triggered by Login entries with two websites + OTP. Single website + OTP obviously does not. I edited a Login entry that was giving me trouble, removing the second website from the list, and immediately the problem went away for that Login. I put the second website back, and boom, problem immediately returns. I have also completely deleted the Login entry and recreated it from scratch, just in case there was some internal schema breakage, but nope. One website? Fine. Two websites on that Login, even with the Login newly re-created, yep the problem returns.

Interestingly, I have one Login entry in my database that has THREE websites + OTP, and I don't see the bug on that Login. Not sure though, I scroll it and the scroll bar I swear looks like it jumps shorter/longer a bit but it's really quick and maybe I'm just fooling myself. It's possible that the bug is triggered on this three-website Login too, but isn't nearly as visible as it is in a Login with two website URLs.

I only have three Login entries in my database that have two websites + OTP, but all three of them exhibit this bug.



Note for the record: I am using a Standalone Vault with 1P, and using Wifi Sync. I am synchronizing to a Mac 1P likewise with a Standalone Vault. I did the Login entry editing from the Mac and synced to iOS. The Mac does not display any problems, but I figured I should note it since, while I personally think this is an iOS bug, it's always possible it's actually a bug specific to wifi sync with this particular type of Login entry. I don't THINK so though, because my database is very, very rarely edited, and thus likewise I rarely need a sync. Pretty sure I started seeing this bug after an iOS 1P app update but without any recent syncing having been done.

Also this isn't an iOS 14 thing; I can definitely can say that. I noticed this issue quite a while ago, early in the year if I remember right (maybe even late last year?), but I just hadn't gotten around to poking at it or reporting it, because overall it's just a relatively minor annoyance. A little scrolling up and down gets past the issue and allows me to use the Login entry normally. Sorry I didn't report it sooner!


1Password Version: iOS 7.6.2
Extension Version: Not Provided
OS Version: iOS 14.0
Sync Type: Wifi

Comments

  • ag_anaag_ana

    Team Member

    Hi @Mousit!

    Thank you for taking the time to report this! I have just tested this in 1Password for iOS by creating a new Login item with 2 website fields, and a TOTP field, and scrolling was smooth for me. The countdown also works as expected.

    I wanted to suggest to try creating a new Login item, but you have tried that already so that won't be necessary. I wonder at this point if there is an issue with the actual contents of the Login item. For example, if you create a new Login item, add two random website URLs there, and a random TOTP field, do you see the same behavior?

  • Hello @ag_ana

    Okay, I tried creating a new Login entry totally from scratch with random data. Also to eliminate questions about Mac and Wifi sync, I did it all 100% from my iOS device only. New Login made, test data thrown in, and I even used an online OTP generator to simply create a new, random OTP that I scanned from QR code.

    Once I have the entry created, I still see the stuttering problem. Quite badly. If I remove the second URL, the stuttering immediately goes away. And then comes back if I add a second URL back in, no matter what the URL is.

    Kind of expected this result, to be honest, since I have three Login entries in my database with this two website + OTP setup--and thus, this problem--and those entries of course already all have different data from each other.

    Only thing I haven't tested is trying to do this from a brand new vault, as there could be some kind of corruption in my vault's schema or such. I've never actually operated with two vaults so I don't even know how to go about creating a second vault on iOS, especially as I'm working with a Standalone setup. The vault on the device now was created from scratch on a Mac and Wifi synced over, as that's typically how I do all my database work; I always create or edit on the Mac and sync. This little test is actually the first time I've ever created a new entry directly on iOS. :)

  • ag_anaag_ana

    Team Member

    @Mousit:

    Thank you for the additional information! I have tested this once again since the last time, and I confirm that I am still not able to reproduce this behavior here. I wonder if you could perhaps send us a short video of this problem, perhaps someone will have some suggestions.

    To avoid posting it on a public forum, can you send us an email to [email protected] if the video is smaller than 20 MBs? We can certainly take a look in private and see if we can spot anything strange.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Hi @ag_ana

    Okay, I sent an e-mail with two small videos. Ticket is [#WQM-11758-525].

    I think they do quite well to show the issues. On the first video, I actually stopped scrolling for several seconds so you can simply see the OTP frozen and not ticking, and then I continued trying to scroll after waiting.

    On the second video, I simply just scroll. And I assure you, despite how slow and jerky it looks, I am moving my finger smoothly and not nearly THAT slow either, thus the issue! I think the second video is the best one, really showing the jerkiness of it and how slowly it responds. If you watch the scrollbar on the right, you can also see it grow significantly longer and shorter in sudden fits, which I think is at least related to the whole issue.

    In both videos you can see there's a point near the bottom of the entry where it suddenly just "unlocks" and starts scrolling smoothly, up and down, and from then on behaves normally, which I demonstrate in the final seconds. From then on it will remain normal, at least as long as I have the entry open. However if I return to the overall Logins list, and then re-open that entry, it'll be back to the jerkiness once more.

    Hope this helps! At least it shows the issue, even if it might not get any closer to solving it. :)

  • Oh @ag_ana I don't think I ever said. My iOS device is an iPhone SE (2016), the first one. Just FYI. Don't know if that has any bearing on this bug but who knows. I've certainly seen other oddities in various apps, related to the SE's particular screen dimensions.

  • ag_anaag_ana

    Team Member

    @Mousit:

    Thank you for the videos and for the additional information! I confirm that I have managed to locate your message in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: WQM-11758-525

  • Hi @ag_ana

    I also replied to the e-mail ticket this discussion is associated with too. I installed the iOS 7.7 update this morning and it looks like it did indeed fix the issue. I poked around in all my various Login entries and everything is smooth scrolling. Thanks!

  • ag_tommyag_tommy

    Team Member

    @Mousit

    That's great news, thanks for sharing. I see that brenty has replied to your ticket. ;)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file