Autofill broke in some site with 2 username/password field after update today

It was working fine yesterday but after today's update, it's broke on website that have 2 username/password fields.
On website that have 2 username/password form on top and in the middle. In the middle field, it's filled username and leave password blank and in the top field it's filled password and leave username blank so can't auto login like that.

I tried save new login to update the form and tried making new login entirely but either doesn't work.
Happened to every site that have 2 username/password field.
ex. https://goshujin.tk/index.php?action=login


1Password Version: 7.6.783
Extension Version: 4.7.5.90
OS Version: Windows 8.1
Sync Type: Stand alone

Comments

  • ag_anaag_ana

    Team Member

    Hi @Justn1!

    I will be happy to test the website, but I have a question for you first: can you please elaborate on what you mean by "2 username/password fields"? If I open the website you linked, I only see one username and one password field. Can you clarify?

  • There're 2 place to type username/password, usually for forum type website (like SMF board) they will have small box for username/password in the corner of every page but there'll be another one in the center on login page.
    That website is not in English, so it might be hard to know.
    I add the image of similar website here. When auto login with 1password, it fill top left box username and middle box password instead of all in the middle field as you see in the image.
    ex.https://www.simplemachines.org/community/index.php?action=login

  • ag_anaag_ana

    Team Member

    @Justn1:

    Thank you for the clarification! I have tested this website and 1Password was able to fill both the username and the password field in the same form:

    What browser is this happening with? For reference, I tested this in Chrome 85.0.4183.102.

  • I tried again and found out that it's happened differently each site.

    On https://www.simplemachines.org/community/index.php?action=login
    It's happen when the curser isn't focus on the username box (like when you access from a bookmarked thread). You can try by clicking outside the box and auto login.

    It's the opposite on https://goshujin.tk/index.php?action=login
    It's happen when the curser is focus on the username box in the middle.

    When the curser is unfocused, it will filled the top field instead.

    I use Chrome 85.0.4183.121

  • Hey @Justn1. I was able to reproduce the behaviors you described. Since things do fill properly when the field is focused first, and the field is focused on page load, what's the circumstance where this is an issue in practice? That is, if you load the page and then autofill, things work properly, right?

  • @ag_michaelc The issue is it doesn't work on https://goshujin.tk/index.php?action=login

    The field is focused on page load but doesn't filled properly on
    https://goshujin.tk/index.php?action=login

    It's only work on
    https://www.simplemachines.org/community/index.php?action=login

    I have a problem on the first website (goshujin.tk) but it's not in English so ag_ana didn't understand which one are the second user/password field. So I tried to find the same forum in English (www.simplemachines.org) to show her where the user/password field is but seems like the problem only happened on https://goshujin.tk/index.php?action=login

  • Hey @Justn1, you're absolutely right. That's my bad. I have submitted this for our development team to investigate further. Thank you for reporting this to us. :smile:

    ref: dev/core/core#2999

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file