Can't install extension in Brave Browser

Fresh install MacOs and 1Password. Chrome extension runs fine. Brave install fails in Chrome Web store. I've tried numerous times (and rebooted the machine) failure is always the same after clicking "Add to Brave" and then "Add Extension"
"An error has occurred"
"Download interrupted"
at the bottom of the browser window
"aomxxx...crx"
"https://go-updater.bra..."
Failed - Server problem

Help! I can't stand Chrome and need Brave. Brave and extension runs fine on my older laptop (MacBook Pro)


1Password Version: 7.6
Extension Version: 4.7.9.50 (latest in store
OS Version: 10.15.7
Sync Type: ?? team
Referrer: forum-search:Can't install extension in Brave

Comments

  • ag_anaag_ana

    Team Member

    Hi @pstocks!

    A server problem suggests that it might be a temporary issue with the Chrome web store. Is this happening with other extensions as well?

  • pstockspstocks
    edited October 3

    This has been going on for a couple of days now. Yes I can add other extension to Brave (just added and removed JSONView) and I did just install Flash (needed by Bank) with no problem. On my old MBPro (which will be flatted soon). I removed the extension and could not reinstall it: same error as on my new machine.

    I've posted this problem in the Brave community forum

  • ag_yaronag_yaron

    Team Member

    Hey @pstocks ,

    I tested this on Brave right now on version 1.14.84 and things seem to work well on my Mac, I was able to add the extension to brave, enable it, remove it, then re-add it again without any issues, so I'd like you to try some basic troubleshooting suggestions and see if they have any effect on the situation:

    • Make sure you're running the latest version of Brave. If it has a pending update, relaunch Brave to install it and see if you're able to install the extension then.
    • Clear Brave's cache, then try adding the extension.
    • Disable any and all extensions, restart Brave, then try adding 1Password's extension.
    • Try connecting to a different wifi (you can try connecting to a hotspot from your mobile phone's internet), then try installing the extension.
    • Reset Brave to default as a last resort, then try adding the extension. You might lose some data here (e.g. favorites) but it will probably work.
  • Tried all your steps plus removed Brave and reinstalled. No change! My MacOS is fresh and the only apps I've installed other than Chrome and Brave are my dev tools (xcode etc.). Nothing else beside your extension appears wrong with my new machine. Have not heard anything from Brave support. The error is coming from their server
    Thanks for your help

  • Problem is not your extension ... its Brave. Its failing downloads for other apps I use (Chrome has no problems). Sorry for the noise and thanks for trying to help

  • ag_anaag_ana

    Team Member

    No worries at all @pstocks, we appreciate the update! Let us know if there is anything else we can do to help :):+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file