Is there a way to turn off address autofills?

tvrnertvrner
edited October 6 in 1Password X

Using 1Pass X in chrome on a mac. Password filling is great, but the address filling isn't working as well as Chrome's built-in autofill. I don't have a specific example, I'm just spending a lot more time typing in addresses manually. I'll click in an address field and 1Pass doesn't seem to be aware it exists. I feel like it was pretty rare that this happened with Chrome's autofill.

Problem is, 1Pass has locked me out of using Chrome's autofill feature. Seems like an all-or-nothing proposition.

Is there a way to use 1PassX for passwords but still use Chrome for addresses?


1Password Version: 7.6
Extension Version: X 1.22.1
OS Version: 10.15.6
Sync Type: Account

Comments

  • ag_anaag_ana

    Team Member

    Hi @tvrner! Welcome to the forum!

    Is there a way to use 1PassX for passwords but still use Chrome for addresses?

    I think technically speaking you can do this, but we generally recommend turning off these browser features to avoid interference with 1Password (so that you don't have two different systems trying to do the same thing). We would love to take a look at the specific websites where this is happening though, so we can continue improving address filling until hopefully this never happens anymore :)

  • Thanks, and ok- next time it happens I'll post back here.

  • ag_tommyag_tommy

    Team Member

    :+1::chuffed:

  • Ok, here's an example. It's not cherry picked, it's just the first form I've needed to fill since I started the thread.

    With 1pass X enabled in Chrome: https://youtu.be/qpPcUoPRCvs
    You can see the only input 1pass recognizes is the email field. Sometimes it's none of the fields.

    With 1pass X disabled (so Chrome autofill is enabled): https://youtu.be/QTbwVJ-_Ik4
    Works the way I expect autofill to work, I can start with any field and the rest get filled.

  • nhat_1Pnhat_1P

    Team Member

    Hello @tvrner, thank you for the recording. It is correct that the inline menu does not show up on other fields besides the email address. However, 1Password should not have issues filling everything correctly if you select the 1Password X icon on the browser toolbar and select your identity items to fill there.

    If you want to use Chrome's built-in password manager for your identity, there is a way to do that. Still, we don't recommend users that option because it is not as secure, less convenient, especially when you have multiple identities, and it could be quite intrusive sometimes. That being said, you can follow the steps here to use to let Chrome fill in your address without having to disable 1Password X.

    Right-click on the 1Password X icon on the browser toolbar > Settings > General > Turn off the "Make 1Password the default password manager" option.

    Copy and paste this link to Chrome's address bar: chrome://settings/addresses > Enter > Turn on "Save and fill" Address option.

  • Thanks for the fix. I'm not sure I know what multiple identities are, but I can store multiple addresses, etc in Chrome mapped to different names. I suppose some of the times I couldn't get 1Pass autofill to work at all, there was no email field to fill. Didn't even know I should be going to the toolbar. Seems easier to me when it happens in-field.

    Anyways, your mod seems to be working well. I'll pipe back up if I have an issue.

    Thanks!

  • nhat_1Pnhat_1P

    Team Member

    Hello @tvrner, thank you for letting me know. Please feel free to give me a shout if you need anything and have a great week.

  • Yes, please allow turning off address filling. It's not on par with Chrome. I have a multi-line address and it fills everything on one line with no space in between. Also, I use a separate shipping vs billing address and have to setup 2 identities in 1 password for this to work. It's just not good enough, so I disabled 1 Password X as a result.

  • ag_yaronag_yaron

    Team Member

    Hey @btzzz ,
    If you want 1Password to stop autofilling identities, simply delete your identity items from your 1Password.

    That way you can let Chrome manage your address autofilling and 1Password for passwords.

  • btzzzbtzzz
    edited October 19

    The solution to this was to turn off "Make 1 Password Your Default Password Manager" in settings. This allowed me to use Chrome address filling and still have 1Password for passwords.

  • nhat_1Pnhat_1P

    Team Member

    Thank you for your feedback. I am happy to hear that the suggestion to turn off 1Password as a default password manager works. 1Password will never automatically fill in your input fields, so you should not have issues using Chrome to fill your addresses.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file