Autofill not working on Bank of America app

Just got a new Pixel 4A and it looks like Autofill is not working on the Bank of America app. I think the problem is the app requires you to type your username first (I can't fill in my password first even if I try to do it manually) and this restriction is probably screwing with the autofill somehow. Hope you can get this fixed, it's issues like this that make it difficult for me to recommend password managers to less technically inclined friends and family.


1Password Version: 7.7
Extension Version: Not Provided
OS Version: Android 11
Sync Type: 1Password

Comments

  • ag_audreyag_audrey

    Team Member
    edited October 9

    Hey @dparsons85, thanks for reporting this!

    Can you try turning on only Autofill and only Accessibility and seeing if either works? This will help us narrow down the issue.

    Could you also try creating a test Login item and logging in to the app?

  • Thanks! Looks like turning off Autofill and keeping Accessibility checked worked - I'm now seeing the autofill bubble popup for the BoA app. Turning off Accessibility and keeping Autofill checked did not work.

  • ag_audreyag_audrey

    Team Member

    @dparsons85, thank you for doing the tests for me!

    This is unfortunately a known issue that we are currently working on. I wanted to confirm that you are experiencing the same behaviour, so I've gone ahead and passed this along to our development team.

    In the meantime, please use our drag and drop feature: https://support.1password.com/getting-started-android/#drag-and-drop-to-fill-in-other-apps.

    ref: dev/android/onepassword-android#955

  • Thanks! What if I just kept Autofill unchecked though? It seems to work that way. Do you think that would mess it up in a future update?

  • ag_audreyag_audrey

    Team Member

    @dparsons85, great question.

    Unfortunately, using only Accessibility may work on the Bank of America app, but if you try filling on other apps, filling may not work since they may require enabling Autofill.

    Nothing would get messed up, but I wouldn't recommend it.

  • Gotcha. It appears to be working on all apps now that I've unchecked Autofill so I'll just keep it that way until I run into an app it won't work on.

    The only difference I've noticed is instead of giving me an autofill option that appears at the top of the keyboard the Autofill option now appears as a popup that floats near the username/password.

  • ag_audreyag_audrey

    Team Member
    edited October 10

    @dparsons85, thanks for providing your workaround!

    The Gboard suggestion strip requires Autofill and was an update released in 1Password 7.7 for supported apps and browsers. The Autofill prompt behaviour that you're describing was what Autofill looked like before the update.

    If you notice any other apps with filling issues, please let us know!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file