Firefox Browser Extension Not Working

fanchergwfanchergw
edited October 14 in 1Password X

I have installed the 1Password desktop app, and it appears to be working fine. I have also installed the 1Password X browser extension in Firefox. However, when I log into a website it doesn't react at all. Your website even confirms that it is installed.

I have tried rebooting my computer, executing '1password.exe setup' in the Run interface, and nothing has changed. I do notice that the 1Password icon in my browser has a little lock symbol on it, and I don't know if it is supposed to look that way or not. (See attached image.)


1Password Version: 7.6.785
Extension Version: 1.22.2
OS Version: Win 10
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @fanchergw! Welcome to the forum!

    However, when I log into a website it doesn't react at all.

    When you say that the extension does not react, is it locked when it does that? From the screenshot you posted of how the icon looks like in your browser, 1Password X is locked, so it won't do anything until you unlock it, so I wonder if this is why this is happening.

  • Hi Ag_Ana,

    I haven't seen the icon look any other way. How do I unlock it? I signed up and installed the software yesterday, so I know it is the newest version. Why is this the default status? Shouldn't it be unlocked when I log into 1Password desktop app?

  • edited October 12

    The 1Password X browser extension doesn't interact with the installed software at all, it's completely standalone. So you'll need to click that extension icon in Firefox and unlock it there in order to use it on the web pages. Once you click on it, if you haven't signed in at all before, it should open a new page with a button to click to sign in. Once you do that, you should see the extension icon without the padlock. If you'd rather not sign in to both the program and the extension, there is a 1Password companion extension which does integrate with the desktop program, but you don't get the same auto-fill feature (doesn't feel as "polished" to me, at least); instead, the 1Password mini window pops up. But note this and 1Password X are completely different extensions

  • Nothing happens when I left-click the icon. Nothing at all. If I right-click it, then I get the standard Firefox extension menu, which doesn't have any kind of option for unlocking.

  • ag_anaag_ana

    Team Member

    @fanchergw:

    Do you have any other extensions installed alongside 1Password X in your browser? I wonder if there is some interference going on, because clicking on the 1Password X icon in the browser opens a window where you can enter the Master Password for me.

  • The only other extensions that I have installed are AdBlocker Ultimate and DuckDuckGo Privacy Essentials. I have been wondering myself if the problem may stem from one of those.

  • GregGreg

    Team Member

    Hi @fanchergw,

    If you reinstall 1Password X, does the issue remain? If it does, please check what settings you have in Firefox under "Cookies and site data". Thanks! :+1:

    ++
    Greg

  • I uninstalled and reinstalled 1Password X. The issue has not changed. There isn't a lot under Cookies and Site Data. What should I be looking for or expecting there?

  • ag_yaronag_yaron

    Team Member

    Hey @fanchergw ,

    Some combinations of settings in Firefox might be a bit too strict for 1Password X and may prevent it from functioning. If you have your privacy policy set to "Strict", please change it to "Standard", restart Firefox, then click on 1Password X's icon and see if it launches properly. If it does, you can then switch back to "Strict".

    If your privacy policy is "Custom", make sure that at least one of the following settings is disabled:

    • Never remember history.
    • Always use private browsing.

    If both of these options are enabled simultaneously, 1Password won't be able to function.

  • The main privacy setting is - and has been - Standard, as specified. I changed Never Remember History to Use Custom History Settings. Always Use Private Browsing is still set. Do I need to make further changes? I'd rather not turn off Private browsing.

  • ag_yaronag_yaron

    Team Member

    Hey @fanchergw ,
    For the sake of troubleshooting, please set Firefox to remember history (not custom) and to not use private browsing.

    If 1Password X initialized properly and works, you can then revert these settings back and see if it still works. 1Password only needs to create its local files once, then it should work with private browsing.

  • When I turned off Private Browsing mode, it seemed to work fine. I was able to click on the icon, log in, and even save a couple of logins. However, as soon as I turned Private Browsing mode back on, it stopped working.

  • ag_michaelcag_michaelc

    Team Member

    @fanchergw, you'll need to turn off that setting for 1Password X. While in private browsing mode, Firefox prevents extensions from accessing the local database, which 1Password X relies on in order to function properly.

  • fanchergwfanchergw
    edited October 16

    Sounds like I'm going to need a different password manager product. I had been under the impression that they would work together, but apparently that is not the case. This seems like something that should be documented on the main 1Password website so that people know about it before they sign up.

  • ag_yaronag_yaron

    Team Member

    @fanchergw It is possible to work in private browsing with 1Password, but when you turn on "Always use private browsing" it also automatically turns on "Never remember history" it seems. If 1Password can't write data into Firefox's local cache, it can't function. There's no real way around it.

    However, if you turn off the "Always use private browsing" feature, then open a new private browsing window manually, 1Password works as expected. I understand this may be an extra click or two which is not as streamlined as you'd want, so the alternative here is to use our old companion extension alongside the 1Passwod 7 desktop app, which doesn't rely on Firefox's local storage or cache to function: http://1password.com/browsers

  • From what I had read on your website, my understanding was that everything was stored in a vault in "the cloud". That is what allows it to work / sync across devices. Why does it need to write to the local device?

  • ag_michaelcag_michaelc

    Team Member

    Hey @fanchergw. 1Password X runs in a background page; the Background Page LocalStorage is cleared along with site storage when Firefox runs in the always-on private browsing mode.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file