Toolbar button appearance doesn't persist after restart in Firefox for MacOS

Minor bug for you: If I change the badge icon for 1Password X (under 'Toolbar button appearance' in settings) from the default blue-coloured version to the monochrome version an then restart Firefox, it returns to the coloured version again.

I am using Firefox 82.0 (64-bit) (beta channel) for Mac OS X on version 10.15.7 with 1Password X 1.22.4.beta (build #20126).


1Password Version: 7.7.BETA-10
Extension Version: 1.22.4.beta (build #20126)
OS Version: OS X 0.15.7
Sync Type: Not Provided

Comments

  • nhat_1Pnhat_1P

    Team Member

    @fursday I tried to reproduce your issue for a while without success. For that reason, could you please try these steps to see if we can make a difference or not?

    Open Firefox and go here: "about:support" (Without quotes) > Select "Refresh Firefox" > Go here to add a fresh copy of 1Password X beta > Try again.

  • Thanks @nhat_1P.

    Well, I certainly wasn't willing to refresh my profile and loose settings, so tried the above on a freshly created profile and the problem indeed didn't replicate so it looks like it's related to my set up / old config / another add-on

    In any case I just wanted to raise a potential bug but for me it's too trivial to be worth rebuilding my profile from scratch to remedy.

  • One small point though: It might be worth warning users that "Refresh Firefox" deletes their add ons and reverts certain settings to default before advising them to follow this step on their default profile. I checked the implications before doing so but others might not be so cautious.

  • ag_tommyag_tommy

    Team Member

    Thanks for letting us know what you found @fursday.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file