Problems logging in to specific website US Bank

jasimon9jasimon9 Member

I have started using the Brave browser. It is mostly very much like Chrome, but there are a few websites where it does not work properly. How is the 1Password support of Brave? Again mostly it works, but in some cases there might be problems.

In particular I am having a very hard time logging in to US Bank at https://www.usbank.com/index.html. However, this is also happening with Chrome.

Here are the variations with 1Password X:

  • using 1Password X just works as normal
  • 1Password X will not fill in the fields
  • 1Password X will fill in the fields but report as invalid by the website
  • copy/paste from 1Password X and it still fails
  • copy/paste from 1Password X and it works

The above variations all happen with both Chrome and Brave, in a somewhat random distribution. Bottom line that logging in to this website is difficult.

Any ideas?


1Password Version: 7.6
Extension Version: Not Provided
OS Version: 10.15.7
Sync Type: Not Provided

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @jasimon9 ,
    I'm a Brave user myself, and I'll be happy to help you here.

    Brave is a Chromium based browser, so your autofilling experience should be identical to Chrome. The main issue here is probably US Bank's website. Banking websites are very well known for making it extra hard on their users to autofill. So hard, that we actually released an open letter for banks that our users can copy and send to their banks if they'd like: https://blog.1password.com/an-open-letter-to-banks

    However, on this particular website I actually don't see any autofilling issues, so I'd like you to try and create a new login for it like so:

    1. Go to https://www.usbank.com/index.html
    2. Type in your username and password manually into the fields (or copy paste them into the fields) of the login form.
    3. Right click the 1Password X icon on the top right corner of your browser and select "Save Login". Give it a unique name and save it as a new login. Do not update your existing login - make sure to save it as a new one.
    4. Refresh the page, then try autofilling with your new login item and see if it works correctly.

    In case it doesn't work, you can test it again after disabling all other extension except for 1Password and see if it works.
    Let me know how it goes.

  • jasimon9jasimon9 Member

    It just occurred to me that I should add the following information: I continue to have lots of trouble logging in to the US Bank site. This includes autofilling from 1Password X, but also includes just copy/pasting the credentials.

    However, login on their mobile app on my iPhone works incredibly well. It is fast and has less intermediate steps than other sites. For example on Wells Fargo, here are the steps:

    1. Click on Wells Fargo app.
    2. On login page, press on Username field.
    3. At bottom of screen click on "Passwords".
    4. Select 1Password
    5. Login with Master Password (this happens every time, even if 1Password has already been opened)
    6. Type in beginning of Wells Fargo to find the login
    7. Click on the login--the login populates
    8. Click Sign On to log into account.

    This is an eight-step process, not counting entering my long, complex master password. I am wondering if there is some setting making me go through the need to login with master password every time.

    On the other hand here is the mysteriously good process on US Bank mobile:

    1. Click on US Bank app--get popup advising to use touch
    2. Touch ID--logs into account.

    This is a two-step process, and does not require unlocking 1P.

    So something is going horribly wrong on the Wells Fargo login on the iPhone; and something is going wondrously right for US Bank.

    And as I have reported previously, 1P requires unlocking whenever I use it on the phone--except when used for US Bank. Then it is always unlocked.

  • jasimon9jasimon9 Member

    I tried the procedure to create a new login. When doing that, it still would not let me login using the newly created login (not the old one).

  • ag_yaronag_yaron

    Team Member

    Hey @jasimon9 ,

    iPhone is a different world than Mac/PC. When you are using apps on your iPhone, 1Password's ability to autofill depends on whether or not the developers added a link to their website in the app's metadata. If they did, 1Password would then know to connect between the app and the login item you have in 1Password, otherwise you will have to manually locate the login item and select it in 1Password.

    As for 1Password always asking your Master Password, you need to set up Touch ID in 1Password's settings, which will make your life a whole lot easier when autofilling: https://support.1password.com/touch-id-ios/

    The US Bank's app was designed to work with Touch ID regardless of 1Password, which makes it super easy to log into. If only their iPhone developers were also in charge of the desktop website's login, huh? :)

    Back to the desktop - I tried once again to replicate your issue in Brave but things still seem to work ok. Here's a video recording I made for you: http://recordit.co/YwdUTRgrgW
    As you can see, autofilling works correctly, and the password that is being autofilled is the correct one that I saved initially, so if I had a real account that should have worked fine.

    Can you let me know at which step of the way things go wrong there? Are you able to autofill correctly but only after you click on the login button do you get an error that the username or password are incorrect? When you reveal the password after autofilling, is it the correct password of your account?
    And lastly but most importantly, does this only happen in Brave? Or are you able to replicate the issue in Chrome or any other browser?

  • jasimon9jasimon9 Member

    Touch ID is already enabled. And it used to work without having to unlock 1P. In fact the odd thing is that for US Bank, 1P does not have to be unlocked. Just click US Bank icon, thumb on button--logged in! For Wells Fargo, it is the complicated procedure described above every time, and the unlocking of 1P almost every time but not always. This does not make sense to me.

    Regarding autofilling on the desktop--for US Bank the autofilling works and always has. What does not work is that the password gets rejected about 50% of the time and accepted the other 50%. Of course, this makes no sense either.

    The same issues happen in Chrome and Firefox.

    Although here is something: if I wait 5 seconds between the steps of (1) go to site; (2) click login button; (3) wait after autofill before submitting--it seems to work with higher probability. Not sure about this yet; still experimenting with it.

    One other variation: sometimes when I go to US Bank website on desktop, I have to click autofill button to trigger autofill. Other times the dropdown opens and it autofills by itself.

  • ag_michaelcag_michaelc

    Team Member

    Hey @jasimon9. If you are filling the same Login item on your desktop each and every time, but sometimes the password is accepted and others not, it sounds like US Bank is doing something strange with their page, potentially attempting to block password managers in some way. The open letter to banks Yaron linked would be great to send their way, if you haven't already done so.

    There is one thing that strikes me as curious here:

    One other variation: sometimes when I go to US Bank website on desktop, I have to click autofill button to trigger autofill. Other times the dropdown opens and it autofills by itself.

    The dropdown opening automatically can depend on the exact page being loaded (whether the field has focus, and whether the field makes use of autocomplete="off"), but 1Password never autofills without your explicit action — clicking that login in the inline menu, or clicking the Autofill button in the 1Password pop-up. Are you indeed seeing a password fill on page load sometimes, without your actually telling it to? If so, that sounds like there might be a saved password in your browser itself that is getting filled, which could in turn explain why sometimes the password works and others it doesn't.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file