Username not populating on portal login page

I have a portal for my work that I log into, but the User ID field doesn't get populated with the 1Password Autofill. The password does, but not the user name. I have to manually copy it.

In looking at the HTML, I believe the issue may be that they have coded the User ID field as type=Password, I think because they want to mask that field on the form.

Is there any way to get 1Password to populate this, or would the site have to change how the field is coded? This is the fields HTML.


1Password Version: 7.6
Extension Version: Not Provided
OS Version: OS X 10.15.7
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @Murphybp2!

    Without looking at the actual website it would be difficult to say for sure and test this, but if the field is indeed set to "password", it would explain why the username field is not filled. I think it's likely that if the User ID field was marked as username, 1Password would very likely work without any additional updates.

  • Here is the site. https://leplb0060.portal.hewitt.com/web/allstate. It looks like the HTML I tried posting didn't save. Here it is again.

    <input class="aui-field-input aui-field-input-text" id="_ParticipantLogon20_WAR_ahcommonauthportlet_userId" name="_ParticipantLogon20_WAR_ahcommonauthportlet_userId" placeholder="User ID" type="password" value="">
    
  • ag_anaag_ana

    Team Member

    @Murphybp2:

    Thank you for sharing the URL! I have tested the website, and I was able to fill both username and passwords fields right away. What version of the 1Password browser extension are you currently using?

  • I have the most recent 1Password app (7.6), and I used that to install the browser extension for Safari. I don't see anywhere that lists a separate version for the extension for Safari. I also tried with Chrome and didn't work there either. That extension version is 4.7.5.90.

  • Are you on a Mac or Windows computer? I have a Mac for home, but I use Windows for work. I did just try the site using Edge on my work computer and it worked for that. So this must be a Mac issue.

  • Murphybp2Murphybp2
    edited November 13

    Wait, I'm using the 1Password X extension at work. At home I'm using the extension that is part of the app, which I guess is different. So maybe that's the issue?

  • ag_anaag_ana

    Team Member

    @Murphybp2:

    I tested this on Mac, in Chrome browser with the 4.7.5.90 browser extension, so that should work for you too. The only difference is that I am running the latest version 7.7 beta. Often there are improvements in filling in the betas before we release them to the stable app, so it's possible that this is something that was addressed in one of the last beta updates.

    If you would like to give the beta a try, here are the instructions:

    Use 1Password beta releases

  • It doesn’t work on my Mac with Chrome or Safari. I primarily use Safari so that’s where I’d like it to work.

    What are the steps you took to test it?

  • Ok, I installed the beta release and now it works. So then there must be something it fixed/enhanced since the 7.6 release.

  • ag_anaag_ana

    Team Member

    Thank you for the confirmation @Murphybp2! This is good to hear :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file