"New fill experience" covers up the rest of the dialog!

In Safari 14.0.1 on MacOS 10.15.7 the 1 password fill dialog blocks the existing fill from Keychain and often covers up the submit button. Is there a way to revert to the old fill experience? I don't always use 1Password and now it's really difficult to use Safari's built-in fill.


1Password Version: 7.7
Extension Version: 7.7
OS Version: MacOS 10.15.7
Sync Type: Dropbox
Referrer: forum-search:safari fill experience

Comments

  • Also seeing this and cannot work out how to switch it off. Incredibly frustrating :(

    Can anyone help please?

  • rudyrudy

    Team Member

    1Password -> Preferences -> Browsers -> Safari

  • Thanks for the tantalizing hint but what do we do when we get there? I'm not watching every bit of update news from every software vendor. I just want my software to work.

  • ag_anaag_ana

    Team Member

    @PeterCook:

    Once you are in the Browsers tab of the preferences, please uncheck the option named Show inline menu in Safari, or at least the Automatically show inline menu when selecting a field, depending on your preference.

  • Thank you.

  • BenBen AWS Team

    Team Member

    On behalf of Ana you're most welcome. :)

    Ben

  • The new inline interface is VERY obtrusive. I am trying to get my sister to buy 1PW, but she HATES it during the trial period. I am confused as to why it seems to battle with Apple's own interface in Safari unless I turn it off. If I can't choose 1PW OR Apple's interface I am going to choose Apple's because I can't turn that one off. Unless 1PW interface can coexist with Apple's pw interface AND enhance the password experience, it is no win at all. I recommend you watch a brand new-naive use try to use it, because I have and it is VERY unfriendly to them.

  • BenBen AWS Team

    Team Member
    edited November 22

    Hi @twojtyniak

    It is possible to turn either 1Password's inline menu or Apple's Password AutoFill off. Instructions on turning the 1Password inline menu off are found above, but to reiterate:

    1Password -> Preferences -> Browsers -> Safari -> Uncheck Automatically show inline menu when selecting a field

    This way you'll only see the 1Password UI when clicking on the 1Password icon or activating it using the keyboard shortcut. That said we strongly recommend against storing passwords in both Apple's solution and 1Password, as that is very likely to lead down a path of confusion. e.g. which one is it in? Which one has the latest version? etc.

    Thanks!

    Ben

  • I am not clear how to turn off Safari suggesting secure passwords, which seems to battle with 1PW. And, honestly, Safari does a better job capturing passwords in some cases than 1PW, so I use both. I'd love to fully trust 1PW, but my experience is that it misses too many things. And my sister, a new user, has been very disappointed by the number of things actually saved for her as well as the UX.

    I appreciate the complexity of the task. And it is what your product is built to do. I am a fan, mostly. The UX is key, IMO, to making a great product.

  • ag_anaag_ana

    Team Member

    @twojtyniak:

    I am not clear how to turn off Safari suggesting secure passwords, which seems to battle with 1PW

    Here are the instructions:

    Turn off the built-in password manager in your browser

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file