Safari extension and mini 1Password in OS X Menu doesn't work..... (on 7.7 and BigSur)

yashvindyashvind Junior Member
edited November 2020 in Mac

1Pwd 7.7 and Big Sur 11.0.1 - the safari extension doesn't work. It stays 'yellowish' . Also, the 1Password from menu bar is not working. See here for the actual system interaction demo - https://streamable.com/bx66sa


1Password Version: 7.7
Extension Version: Not Provided
OS Version: 11.0.1
Sync Type: Not Provided
Referrer: forum-search:safari extension not working

Comments

  • edbroedbro
    edited November 2020

    Same for me. The extension doesn't work, the menu bar icon doesn't work and the 1PW icon that shows in login boxes doesn't work. I can't believe this was beta tested.
    OS 11.0.1 - M1 Mac Air
    1Password 7
    Version 7.7 (70700016)
    Mac App Store

  • Same for me, please help

  • This is infuriating. 1password 7.7 extensions don't work in any browser and I have tried Safari, Firefox and Chrome. When I click on the
    Safari 1p icon a window opens asking me to enable 1p. I click in the window which opens up the extensions window. I uncheck and check the 1p app, asks for confirmation but still doesn't work. On chrome it doesn't recognize that I have the desktop app installed.
    Nothing at all happens on Firefox. I noticed that this from the community that this wasn't working on 7.7beta but you released a broken
    version anyway. What a time suck. You knew this bug existed, didn't fix it and released 7.7 anyway. This is inexcusable and come close
    to negating any utility that 1p has, especially when there are alternatives. You need to fix this NOW!

  • ag_anaag_ana

    Team Member

    Thank you for the reports, and sorry about this! I would like to ask you to generate a diagnostics report from your Mac and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • yashvindyashvind Junior Member
    edited November 2020

    Support Ticket - [#XAN-87277-794]

    ref: XAN-87277-794

  • Same issue here. 7.7 is just not working in Safari, Big Sur!

  • I'm seeing the same issues and have submitted a diagnostics report - #GYT-44656-127

  • I reviewed a past issue I had when I installed an older 1Password update. At that time your support group suggested that I reboot my Mac to fix the issue which solved the problem. I just tried it again - I rebooted my Mac. 1Password 7.7 in conjunction with Safari is working as expected.

  • I am also seeing the same issues. My support ID is #EMQ-95764-512. I submitted my diagnostics report.

  • Try shutting down to reboot your computer. Then see if 1Password and your browser work

  • bcwolvenbcwolven
    edited November 2020

    Same issue here. Rebooted, didn't help. I did notice that 1Password Mini will work as long as Safari does not have focus.

    Running 11.0.1 on a MacBook Pro (Retina, 15-inch, Mid 2014).

  • Just rebooted. It did work. Thank you.
    I don't believe its obvious. I think you should make it so.

  • ag_anaag_ana

    Team Member

    Thank you everyone for the updates! A reboot normally solves this. If it doesn't, some users reported that a shutdown helped instead. Otherwise, please feel free to send us your diagnostics report and we will be happy to take a look at why this is happening to you :+1:

  • I have the same issue

  • ag_anaag_ana

    Team Member

    @brianfwalsh:

    Have you tried some of the suggestions in this discussion already? If you have and you are still experiencing this, have you emailed us a report too?

  • yashvindyashvind Junior Member

    **(RESOLVED) - Steps
    **
    These are the steps that I received from the 1Passoword, and that help fix the issue.

    1. In Safari > Preferences > Extensions, toggle the 1Password extension off and on again.
    2. In 1Password > Preferences > Browsers, toggle the Extension Helper off and on again.
    3. Quit Safari.
    4. Right click (or click while holding the Control key) the 1Password icon in your Mac's menubar and select Quit 1Password Completely.
    5. In System Preferences > Users & Groups > Login Items, verify that neither 1Password nor Safari are listed.
    6. Restart your Mac.
    7. Open and unlock the 1Password desktop app.
    8. Open Safari and test the extension.
  • I have do all those steps and still same problem. I tried to uninstall and reinstall 1password but still nothing. This is very annoying!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file