1Password X requires secret key after every reboot (Firefox Debian Ubuntu 18.04)

After a shutdown and restart, I need to type in my secret key as well as master password. Did not happen with prior version of 1Passwrd X. Firefox is remembering history (set in prefs).


1Password Version: Not Provided
Extension Version: 1.22.3
OS Version: Ubuntu 18.04.2
Sync Type: Not Provided
Referrer: forum-search:[1Password X requires secret key after every reboot (Firefox Debian Ubuntu 18.04.2](https://1password.community/search?Search=1Password X requires secret key after every reboot (Firefox Debian Ubuntu 18.04.2)

Comments

  • ag_anaag_ana

    Team Member

    Hi @svandor!

    Is your Firefox browser set to delete all cookies on quit?

  • Yes, it is. But it’s that way on Mac and Windows, too, with no problems. I’ll try that change on Linux. Seems weird to give up some security to gain the security 1Password brings.

  • ag_michaelcag_michaelc

    Team Member

    Hey @svandor. The Secret Key is stored in the browser's local storage, so if that's getting wiped out, that's going to cause the issue you're experiencing. As to why you're seeing different behavior across OSes, that I cannot say. There could be some other setting somewhere that's just a little bit different. If you install 1Password X in a new profile with these same settings, does the issue persist?

    https://support.mozilla.org/kb/profile-manager-create-remove-switch-firefox-profiles

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file