Firefox extension

SystemSystem

Team Member
This discussion was created from comments split from: Firefox extension is not working anymore.

Comments

  • kevinneufeldkevinneufeld Junior Member

    The following versions:
    firefox: 82.0.2
    1Password 7: Version 7.7 (70700016) Mac App Store
    Firefox Extension: 4.7.5.90

    The 1password of Firefox stopped working, the extension on the toolbar is constantly blinking actively and then greyed out.

    Reinstalling the extension, restarting the firefox nor rebooting mac corrects the issue.

  • ag_anaag_ana

    Team Member

    Hi @kevinneufeld!

    Reinstalling the extension, restarting the firefox nor rebooting mac corrects the issue.

    I am not sure I understand whether these things corected the issue or not. Can you confirm?

  • I can confirm the same thing is happening for me on my MacBook Pro.

    This started occurring after 1Password upgraded itself to v7.7. I noticed it immediately and thought I may need to upgraded from Firefox 82.0.2 to Firefox 83.0 and after I did the FF upgrade it is still blinking. In order to troubleshoot some more I also attempted to reinstall the 1P FF Extension and that didn't work.

  • Since updating to 7.7, the 1Password extension both for Firefox and Brave are also broken for me. Normally I only use Firefox, but I tested with Brave to verify that it's not isolated to Firefox. Clicking either the 1Password menubar item or in-browser button dim very briefly but do nothing. No menu actually pops out.

    I updating Firefox and Brave to the latest versions and restarted them, but that had no effect.
    I uninstalled and reinstalled the 1Password extension in Firefox and Brave, but that had no effect.
    I restarted my whole system, but that had no effect.

    • 1Password 7: Version 7.7 (70700015) 1Password Store
    • Firefox: 83.0 (64-bit)
    • Firefox 1Password extension: 4.7.5.90
    • Brave: Version 1.17.73 Chromium: 87.0.4280.67 (Official Build) (x86_64)
    • Brave 1Password extension: 4.7.5.90

    FWIW, this is on a rather old system running macOS Sierra 10.12, but I've been using 1Password with all of its updates here for years and never had this problem until now. I have another Mac running macOS Mojave 10.14, but 1Password's Firefox and Brave extensions seem to be fine after updating to 7.7 and the latest browser versions.

    Did the 7.7 release drop support for older systems like macOS 10.12? I checked the release notes in the blog post and don't think I saw anything like that.

  • I just found an older version of 1Password 7.6 in a Time Machine backup, and decided to try that out...

    I "Quit 1Password Completely", moved the 7.7 version 1Password.app to the trash, restored the 7.6 version 1Password.app from my Time Machine backup, and reopened it. Surprise! The browser extensions are working again.

    So, there's definitely something broken with the 7.7 version that regressed functionality from the previous 7.6 version. For now, I'm just going to ignore the 7.7 update, but I hope this gets fixed eventually because I doubt staying on 7.6 forever is a viable option.

    The old "working" version I resuscitated was 1Password 7 Version 7.6 (70600005) 1Password Store. @Yo_Ayo if you have backups and can do this, I'd suggest giving it a try.

  • I just upgraded my Mac from Catalina to Big Sur and the problem went away.

    @potatomac are you running MacOS Catalina? The issue might be an incompatibility of 1Password 7.7, the Browser Extension and MacOS Catalina. But everything is working the way they should for me now.

    Just my $0.02

  • @potatomac it definitely sounds like a regression. I was running MacOS 10.15.2 prior to upgrading to BigSur (now I'm on 11.0.1)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file