AWS Change password stopped updating 1password

Very recently, the integration with AWS and change password has stopped saving the password when you change it.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @blairham!

    What version of the 1Password browser extension are you currently using? And could you also share a full URL where this is happening, so we can test it? Thank you!

  • Hi @ag_ana

    Sorry I completely failed to provide any information. I don't believe I can provide you with a full URL as it's AWS IAM User password

    here would be a sample you would have to fill in your own details with
    https://console.aws.amazon.com/iam/home?region=us-east-1#/users/?section=security_credentials

    Changing your password will find your current password but will not save it once you change it, therefore locking yourself out. Also, while I'm thinking about it, it would be nice if 1password would follow the password requirements as there are times I have to regenerate a password a few times to meet the requirements.

    1Password Version: 7.7.1.BETA-3 (70701003)
    Extension Version: 1.23.0
    OS Version: macOS 11.0.1

  • ag_yaronag_yaron

    Team Member

    Hey @blairham ,

    When you generate a password and autofill it, do you not get a popup from 1Password that asks if you'd like to save it as a new login or update the existing one? Here's what it should look like: http://recordit.co/fe9xn1JHTt

  • The first part where is suggests the password, yes that is happening. The second popup does not happen
    https://d.pr/v/1uxOO1

  • ag_yaronag_yaron

    Team Member

    Thanks for the video @blairham .

    Are you able to reproduce it on any other website, or is this AWS specific only? If it happens on other websites as well, then something might have gone haywire with your 1Password extension and we should reinstall it. If it is AWS specific, we'll dive into it.

  • Hi @ag_yaron,

    Sorry took me a bit to get back to this, yes it works on other sites: https://d.pr/v/Sa1ZV7

  • ag_yaronag_yaron

    Team Member

    Hey @blairham ,

    That new video you posted shows you are initially saving a new login with a blank password page. After that, you autofilled that login (which left the password field empty since thats how you saved it), then generated a new password and 1Password did offer to update the existing login, at which point you were able to autofill both fields.

    That's proper behavior and how it should work. Where is the problem in that video? Am I missing something?

  • @ag_yaron you asked if it was working elsewhere, and I showed you it was. But it does not work for AWS password changes. referring back to my first video.

    This issue has caused me to lock myself out of AWS several times because of the password change policy. The only way to do this is to change the password in 1password first then use that password in the edit field. This is less than an ideal process for this don't you think?

    Would it not be easier to just try this on your own it might be easier to see this? What else can I do to prove to you that it's broken?

  • Here how about one from your own site: https://d.pr/v/3auiGn

    It will save my password change from here, but not aws

  • kaitlynkaitlyn

    Team Member

    @blairham – I don't have an AWS Console account to test with, but I want to make sure I'm understanding the issue at hand.

    Changing your password will find your current password but will not save it once you change it, therefore locking yourself out.

    It sounds like you're able to fill your current password using the inline menu underneath the current password field. Are you then filling the suggested password underneath the new password field? Does the same popup in your video for the 1Password.community website appear asking you if you'd like to save the Login item, or is that what's missing?

  • Hi @kaitlyn ,

    First you can create an AWS account and do exactly what I have shown, it's free ;)

    Yes it does exactly as you said, It will use the current password when logging in. But when you are forced to change your password, it will not save/update the password that you just changed it to using the 1password suggestion. If you watch the first video, you will see it makes the suggestion but never stores the updated password, while the second video it does the same thing however it saves/updates the password.

  • kaitlynkaitlyn

    Team Member

    @blairham – Perhaps you could help me out with this since I'm sure you're much more familiar with the AWS Console than I am. I was able to create a Root user, and I can sign in that way, but I'm not able to sign in to the IAM user portion of the sign in form, which sounds like the one you're having trouble with. Do you know if I'm able to create an IAM user for free as well? I was able to find my account number, and I thought that was all I'd need, but that doesn't seem to be the case.

    I have tested the password change process as a Root user, and everything has saved and filled as I'd expect. That's what has made me think that I'm not able to test. Taking a look at your first video (sorry, I had missed that one the first time around), I'm wondering if the modal has something to do with it because that's the main difference I noticed between changing a password as a Root user vs. as an IAM user. Here's what the Root user password change form looks like, for reference:

  • @kaitlyn,

    Let me give you exact steps that should help as you're close.

    Yes, you will most likely need an IAM user, so go ahead and create that. When you create the user, make sure to set it so that you must change the password at next sign-in

    Make sure to add this to your 1password before logging in. Then login as that user; it should ask you to change your password. This is where it no longer stores the new password you have saved.

  • kaitlynkaitlyn

    Team Member

    Thanks for the help, @blairham! I'm wondering how to create an IAM user. That's the part I'm stuck on, but your instructions will definitely come in handy once I can get past that part.

  • Hi @kaitlyn, you should be able to use this as a guide to creating an IAM user

    https://docs.aws.amazon.com/IAM/latest/UserGuide/id_users_create.html#id_users_create_console

  • Hi @kaitlyn,

    I just tried this again and seems it's working again, I'm not sure if the updated version fixed it or not but this doesn't seem to be an issue anymore

    my version is now 1.23.1

  • kaitlynkaitlyn

    Team Member

    @blairham – I'm glad to hear that! The last 1Password X beta update was the 14th of December, but something may have changed on Amazon's end. Please do let me know if the issue creeps back up for you. I was able to create an IAM user thanks to your help. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file