How can I stop these requests to open 1Password?

flibbertyflibberty Member

I'm suddenly getting demands to open 1Password popping up right in the middle of everything. This is really really annoying as it covers up stuff that I am working on and I have to find a vacant piece of desktop to click on to get rid of it. I really don't need this, as if I want to open 1Password I can easily do it myself without this in-your-face prompt. Is there anyway to stop this behaviour?


1Password Version: 7
Extension Version: Not Provided
OS Version: big sur
Sync Type: Not Provided

Comments

  • ag_tommyag_tommy

    Team Member

    @flibberty

    If you are referring to our inline menu, there are several options.

    1. Disable the inline menu completely. 1Password > Preferences > Browsers - Safari, uncheck the option for show inline menu. This will cause 1Password to behave as it previously did before the inline menu.

    2. Disable the automatic inline menu popup. I use this on my Macs. 1Password > Preferences > Browsers - Safari - uncheck the option for "Automatically show the inline menu when selecting a field." Now, whenever you want to access the inline menu, you will need to click the 1Password icon in the field.

    3. Temporarily hide the prompt until the browser is restarted or until you right-click the page and select show 1Password. When the inline menu is shown, click on "Suggestions" and select hide on this page. This is useful if you want the inline menu on other pages.

  • garywan1garywan1
    edited December 2020

    OMG @flibberty THANK YOU for the fix. This problem was driving me mad. I hope that on future updates, 1P understands that some of us prefer to opt-in to new invasive features rather than opt out.

  • ag_tommyag_tommy

    Team Member

    @garywan1

    We're glad to hear you found an answer that helped. That's the benefit of this superb community we have. :chuffed:

  • Hi just adding a comment here so you see it @ag_tommy . I'm also finding this feature very frustrating, i think it could be great, but the popups need to happen somewhere else instead of right underneath a keychain popup. It just looks messy, adds confusion, and seems to be some sort of screen fight with keychain. I've taken option 1 for now but if it co-existed nicely with keychain then i'd happily have it back. could the 1P popup appear anywhere with a 1P themed blue line connecting it to the dialogue box perhaps? cheers!

  • ag_tommyag_tommy

    Team Member
    edited December 2020

    @Adamding

    Noted. Thanks for your feedback. We don't want to get in our users' way. We typically recommend that users disable the keychain to prevent accidentally saving data to one location and not the other. However, there are cases where someone uses both. Perhaps this is something we can improve on in the future.

    could the 1P popup appear anywhere with a 1P themed blue line connecting it to the dialogue box perhaps?

    Interesting suggestion.


  • Will this stop these from popping up? There are some websites i don't want 1P to remember my pass.

  • BenBen AWS Team

    Team Member

    Yes :)

    Ben

  • Thank you very much--I stumbled across this thread and was immediately able to stop this unwanted popup. I found it a bit confusing and inconvenient, and appreciate now having the ability to choose!

  • kaitlynkaitlyn

    Team Member

    I'm so glad you happened to find this thread, @docbombay! That's the beauty of a public forum. :chuffed:

  • camnercamner Member

    I have to note, if for no other reason than the irony of it all, that for those of us who had been enjoying 1PX for Chrome (and being frustrated by the relative lack of capability of the 1P extension in Safari), it was a pleasant surprise to see the new features that the upgrade brought to Safari. That said, I understand why the sudden significant change in the way 1P integrated with Safari could be annoying to those who were both used to and liked the way things worked in Safari before.

  • BenBen AWS Team

    Team Member

    Heh, indeed. An unfortunate case of not being able to please everyone (at least not by default!). Fortunately there are settings that can be adjusted to make 1Password continue to work in Safari just as it did before.

    :+1::)

    Ben

  • Thank you for having this option to stop the popups... i was getting so irritated by the popups, in Safari, basically covering important information and parts of the dialog I needed to see.. I for one like to choose what I do, and not have automagic windows popping up all the time.

    Terri

  • ag_tommyag_tommy

    Team Member

    Understood. I like options myself. :chuffed:

  • I was so irritated by the popups that I cancelled and deleted 1password. The joke is on me because the popups continue. How do I make it stop? My account is no longer active and 1password doesn't recognize me. Thanks in advance.

  • ag_tommyag_tommy

    Team Member

    @Jrok

    Where are you seeing this behavior? From which browser? Off-hand it sounds like your browser extension may still be active. Have you removed it?

  • I primarily use Safari, but also had password on Chrome.

  • Thanks, ag_tommy. I think that resolved the issue.

  • ag_tommyag_tommy

    Team Member

    If not, you know where to find us. We'll be here to help. Forgive a little late evening humor on my part. My day err evening is finally winding down. :dizzy:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file