MacOS Client is Extremely Slow

edited January 9 in Mac

I have been experiencing constant stutters in the client for quite some time now--whether it is adding a new password or simply opening the application. This post will detail all the issues I have been facing.

  1. The start up of the app takes unbelievably long after locking the app:
    Video
  2. Creating new items also takes ages:
    Video
  3. Same problem with switching between vaults and moving items across vaults:
    Video
  4. Also, the application takes up to 2.52gb of RAM:
    Screenshot

I have noticed that after reinstalling 1Password, the app flies again without any stuttering. After a while, it becomes slow again. I tried Betas and stable releases, none solved the issue.


1Password Version: 7.7
Extension Version: Not Provided
OS Version: 11.1
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @privateUser! Welcome to the forum!

    I would like to ask you to generate a diagnostics report from your Mac and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • I have the exact same problem, would be very eager to find out what the outcome is of your work. Restarting the app also fixes it temporarily, on my machine. It's a recent problem. The app accumulates some cruft in memory, and certain operations (editing an entry, unlocking the vault, ...) get slower over time.

    Currently on v7.7 (70700015), Mac 10.15.7.

  • ag_anaag_ana

    Team Member

    Thank you for the confirmation and for sharing the workaround that worked for you @Hraban :+1:

  • @Hraban Hm, I was starting to suspect it's Big Sur-specific problem, but then I noticed you're on 10.15.7. I also believe fully closing 1Password (through activity monitor) also helps it reset back to normal.

  • ag_anaag_ana

    Team Member

    @privateUser:

    This is indeed what we also see in our testing. Our developers are investigating these reports, so hopefully they will have an update soon :+1:

  • edited January 15

    I'm having the same problem as well. Constant Spinning Beachball of Death whenever I try to use the Mac client. Sometimes it goes for as much as a minute without doing anything.

    I've tried closing 1Password completely, but it doesn't fix the problem.

    (I'm running Big Sur and the latest version of the 1P app)

  • ag_anaag_ana

    Team Member

    @Mr. Laser Beam:

    Are you quitting 1Password completely by right-clicking on 1Password mini in the menu bar at the top right of your screen > Quit 1Password Completely?

  • I'm having exactly the same issue and it started somewhen mid December. Closing 1Password completely - which often works only via System Monitor - temporary fixes the issue, but after a couple of days it's back.

    (System: latest macOS 11.1 Big Sur, Brave broswer, latest 1Password 7 app)

  • ag_anaag_ana

    Team Member

    Thank you for letting us know @hobitobi, and thank you for your patience while our developers continue to investigate this :+1:

  • I have the same problem, but this occurred after I upgraded my subscription to Family Sharing. Slow spinning pinwheel when moving items from personal vault to shared vault, and even viewing different vaults. I just upgraded the subscription yesterday and that is when the problem started.

  • ag_anaag_ana

    Team Member

    @gdevine:

    Thank you for the information! For confirmation, are you also using Big Sur and 1Password 7.7.?

  • Yes I experienced the slowdown using 1password 7.7 and Big Sur 11.1. Just a note: I have a Dell laptop running the latest version of Windows 10. The Windows laptop does NOT have any issues, only the Mac misbehaves

  • ag_anaag_ana

    Team Member

    @gdevine:

    Thank you for the confirmation :+1: And that is correct, this issue is specific to 1Password for Mac, it does not impact 1Password for Windows, 1Password for Android or 1Password for iOS.

  • As I've been experiencing the same rapid decline in speed of the macOS client, I hope to add some details or assistance.

    1. It almost seems like the speed declines exponentially. I'm inclined to think it is related to the number of clicks or interactions rather than time.
    2. The only relief I have found has been to quit the app and then Option-Click the menubar icon to Quit 1Password Completely. Sometimes it takes many attempts for this to actually work.

    It seems something has gone rogue with the app.

  • edited January 20

    @elDub That is the exact same problem I am experiencing. I would edit and add new items and notice that the client is steadily becoming slower. It would slowly take longer and longer to switch, edit and add items. Force quitting everything-1Password related in the Activity Monitor would solve the issue.

    The problem might be with the way 1Password is fetching data off the server, loading items, or something of that kind. This bug can be easily replicated by switching between different vaults and clicking on one of the items, then repeating the whole procedure again, and you'll start noticing that it takes 1Password to load stuff longer and longer and the amount of ram used by the client would eventually reach over 1GB and at that point it would become completely unusable. I have also noticed that items should have some data in them, not just an item's title and empty fields (meaning you should test it on an realistic example). While doing this procedure, you'll notice, in Activity Monitor, that each iteration of this procedure would cause huge spikes in the ram consumption and would quickly climb hundreds of MB. Also, assume it climbed to 200MB and you just leave 1Password opened without touching it, the ram will stay stuck at that 200MB mark and would not go down--I had it stay exactly at 216MB for like 20 minutes while I was not touching it.

    I hope this information helps and you'd be able to replicate this issue using the method I've outlined.

  • vishalshethvishalsheth Junior Member

    I'm also facing slow functioning of the 1password app on Mac. I think this has to do something with the new update of the software.

  • ag_tommyag_tommy

    Team Member

    @vishalsheth

    We are continuing to investigate reports of this behavior. You can try to quit 1Password completely and restart which may help.

    • Look for our helper in the menu bar near the WiFi indicator and the clock. Right-click on the helper and select quit 1Password completely. Wait a few seconds and then open 1Password from the Dock or the Applications folder.
  • vishalshethvishalsheth Junior Member

    I have quit 1Password and restarted but it's good for sometime only. I restart my machine everyday in the morning and shut it down in the evening. So that's not the issue. There's something else playing a role in slowing the processing. It's something in your program that has changed. It used to save previously used passwords. This is also not available now. There's some major change in your app.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file