Data is slow to sync across devices

SystemSystem

Team Member
This discussion was created from comments split from: Force Sync.

Comments

  • Gmail at work forces me to update my password every 30 days. Every time I do it on my Mac, the sync to iOS takes days if not weeks to sync up. I have tried forcing a sync to no avail. I am syncing via a 1Password account and am on iOS 14.3 and Mac OS Big Sur. I've tried locking and unlocking to no avail. Any other ideas? This has been happening to me for months if not a year, every 30 days. It's getting really old.

  • ag_anaag_ana

    Team Member

    @Michael H. Smith:

    When you update this item on your Mac, does the change sync right away to the 1Password.com website? It would be useful to understand if it's your Mac which is the problem in the sync, or your iOS device.

  • I never use the website, so I have no idea. I use the iOS app and the Mac app. That's it.

  • Dayton_agDayton_ag

    Team Member
    edited January 12

    Hi @Michael H. Smith, I'm really sorry you're running into that issue! I'd be happy to help take a deeper look at this - send us an email at [email protected] and we can continue our conversation over email.

    Once you send your initial email, you should receive a reply with a conversation code that will look something like this: [#ABC-12345-678]. When you've received that code, could you paste it here? That will help me track down your message, and we can keep the ball rolling from there. Thanks! :smile:

    P.S. I've moved this conversation to the Memberships section.

  • MickMMickM Junior Member

    I'm having the same issue. This all used to work, but I don't know when it broke or got flakey i.e. it could have been this way for some time. On my computer at work I edit an entry in 1Password7 (setup to sync via iCloud) and when I get home later that day the changes are not synced there. While at home I then chang a different entry in 1Password7 on my Mac and right after performing that edit I see the change I had made at work spring to life. Next day I go to work and annoyingly I do not see the change I made at home the previous evening. If I look at the 1Password preferences at work and go to the sync tab it says the last sync was 18 hours ago i.e. it never synced the change I made at home :-(. Everything else about iCloud appears to working fine, just not 1Password. Note that the computer in the location I'm not at would be asleep whenever I'm editing a 1Password entry - that's always been the typical case though...
    Is there a way to force a sync?

  • ag_tommyag_tommy

    Team Member

    @MickM

    What we suspect might be happening here is that the 'notifier' that 1Password uses to get word that it needs to sync is being blocked somewhere in your system. Either on your computer or at the network level. Switching vaults from one to another and back again may be the best option. Several users here in the forum have reported that helped, and items appeared as expected. The development team is investigating reports such as yours.

  • MickMMickM Junior Member

    Yep -- that did it. I created a dummy vault and then switched back to the original vault and all my updates were present. I checked the preferences and it said the iCloud vault was updated 10 secs ago. Looks like you guys have some debugging to do :-)

  • ag_anaag_ana

    Team Member

    Thank you for the update @MickM! I am happy to hear that Tommy's suggestion helped :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file