Groups permissions and individual permissions

Hello,

using the 1Password.com website, we set the permissions of a Group "Team Members" to "View" only.

Members of that "Team Members" group have access to a single vault. When I look at a member's permission in 1Password, it still shows "View, Edit, Export" permissions.

How can I change these permissions on a group?

I don't see an option to set permissions on a vault either.

I would prefer not to have to go through each team member individually to change a shared vault's permission.

Any ideas?
thank you!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • ag_maxag_max

    Team Member

    Hi @mario_dv! Welcome to the 1Password Support Community. I'd be happy to help with your question concerning permissions. :)

    With 1Password Business and Teams, users can maintain access to a shared vault on both a group and individual basis. If you would like for every member of the Team Members group to only view items in a shared vault, you can remove each user from the People section of that particular Vault Details page from the 1Password.com web interface. After each user is removed from the People section, they'll only maintain permissions to that vault on a group basis.

    To update group permissions for a shared vault, click the cog next to the Team Members group, under the Groups section of the Vault Details page. While it may take a little doing to remove each individual from the People section, this will ultimately make it easier to tailor permissions for the Team Members group as a whole going forward.

    To learn more about changing the permissions for a group or individual in your team, check out this article:

    Create, share, and manage vaults in your team

    Let me know if you have any additional questions!

  • Ah! Thank you!

    So individual People added to a vault overrides the Groups. Got it.

  • mario_dvmario_dv
    edited January 13

    OK, so I removed individual users from Vaults in order for the Groups to take over.

    Here is one example where I lost access to a Vault:

    • I created a group "Administrators" and gave myself "Manager" permissions
      [removed by 1Password staff — this is a public forum]

    • I added the "Administrator" group to a vault "Production Management"
      [removed by 1Password staff — this is a public forum]

    The problem is I can not see the "Production Management" vault in my "All Vaults" view.
    [removed by 1Password staff — this is a public forum]

    Only after I add myself in "People" to the Vault will it show up for me.
    [removed by 1Password staff — this is a public forum]

    That is not what I expected. I was expecting to see this vault as I am the manager.

    Thank you!

  • ag_maxag_max

    Team Member

    @mario_dv

    Just a quick note, as your screenshots contained names and other private information not suitable for this public forum, I've just removed them from your post.

    The "Manage" setting allows a user (or in this case, everyone in that group) the ability to grant and revoke access to a particular vault, change permissions for others, and delete the vault.

    However, in order to see the Production Management vault from your Home page, you'll need to click the cog next to the Administrators group and check the View items permission from the Vault Details page. This will then display the Manage & View permissions from the Vault Details page.

    You will then see the Production Management vault from your main list of vaults on your Home page. :)

  • Thank you! That worked

  • ag_maxag_max

    Team Member

    You're very welcome, @mario_dv!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file