CLI Proxy support

Hi,

CLI tool is ignoring underlying proxy settings in Linux environment. That is causing tool not to work behind corporate proxy environment.

Implementing FW rule is not an option by company policies.

Any plans to support proxies for CLI tool?

Proxy settings:

[~] $ env|grep proxy
http_proxy=<redacted>
https_proxy=<redacted>

Internet access via proxy works fine:

[~] $ curl google.com
<HTML><HEAD><meta http-equiv="content-type" content="text/html;charset=utf-8">
<TITLE>301 Moved</TITLE></HEAD><BODY>
<H1>301 Moved</H1>
The document has moved
<A HREF="http://www.google.com/">here</A>.
</BODY></HTML>

CLI tool will not reach the servers:

[~] $ op signin my.1password.com <redacted> --raw
[ERROR] 2021/01/19 10:41:17 Couldn't connect to the sign-in address you provided. Check the address and your network connection, then try again.

1Password Version: 1.8.0
Extension Version: Not Provided
OS Version: Linux
Sync Type: Not Provided
Referrer: forum-search:CLI proxy

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @jaz_111 ,

    The CLI tool should definitely work properly while using a proxy, there are no special settings for it. Support for proxies comes straight out of the box in Go (the programming language used to build the CLI).

    Just to make sure, we set up a local proxy server (Fiddler), set our http_proxy environment variables to redirect network request through Fiddler, and were able to see that op works just fine.

    So the most likely culprit is the format/structure of your http_proxy and https_proxy environment variables. Are you able to share the value of your https_proxy and http_proxy environment variables, either here on the forum or via email if you prefer not to share it in public?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file