Bug in 1.24.0: 1PX no longer matches logins that don't have https:// in the website field

cryptochromecryptochrome Junior Member

Hi,

I just noticed that my 1P no longer automatically finds logins when autofilling usernames and passwords on websites. Upon further research, it turns out that it affects all logins that don't have https:// or http:// in the URL/website field of the login.

For example: I have several logins saved for discord.com. Some of them only have "discord.com" saved in the website filed, some have "https://discord.com". When logging in to discord.com, 1PX only offers those logins that have https:// in them.

This always worked fine until 1.24.

Google Chrome on macOS. Haven't tested with other browsers.

Cheers
Sascha


1Password Version: Not Provided
Extension Version: 1.24.0
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • ag_yaronag_yaron

    Team Member
    edited February 1

    Hey @cryptochrome ,
    Thanks for reporting this!

    We're investigating the issue. While I was able to reproduce it on the latest beta, our internal builds do not suffer from this bug and it seems the next release should fix it.

    We appreciate the report and the investigation you conducted. Thank you very much :+1:

    ref: dev/core/core#4701

  • cryptochromecryptochrome Junior Member

    That's good to hear. Thanks @ag_yaron

  • ag_yaronag_yaron

    Team Member

    No problem. Hopefully a new beta will be released with a fix soon :)

  • ag_michaelcag_michaelc

    Team Member

    Hey @cryptochrome. You might have noticed already, but I wanted to follow up and let you know that this has been resolved in both the stable and beta channels. :smile:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file