1Password auto-lock settings on Chrome OS

Although not officially supported, I installed 1Password 7.7.3 (through Google Play) on my Chromebook running Chrome OS 88.

I've disabled 1Password's auto-lock features and set a PIN code.
Despite those settings, I need to re-enter my master Password each time I re-open 1Password.
It seems like I need to keep 1Password enabled or the app assumes that I restarted my Chromebook after quitting the app (not quitting/restarting the Chromebook)

I've also installed the Chrome browser extension, which seems to work as expected.
I started off with a community search but couldn't find any similar topics yet.


1Password Version: 7.7.3
Extension Version: Not Provided
OS Version: Chrome OS 88
Sync Type: Not Provided
Referrer: forum-search:chrome os

Comments

  • ag_audreyag_audrey

    Team Member

    Hey @kennyvl, thank you for reaching out to us on the Forum. I'm happy to hear you've installed both the Android app and 1Password in your browser on your Chromebook!

    Your 1Password data is encrypted with your Master Password and can only be decrypted with your Master Password. When you enable PIN Unlock on an Android device, this allows you to open 1Password without entering your Master Password while the app remains decrypted. As long as you've unlocked 1Password on your Android device and leave it running in the background, it will be open when you go back to it.

    However, when you fully exit 1Password, swipe it closed from recent apps, or restart your device, the app encrypts again. This means it needs to be decrypted with your Master Password again when you launch it. You can learn more about the scenarios here: https://support.1password.com/android-pin-code/#get-help.

    Therefore, I'd recommend using Biometric Unlock instead, as it is more secure and will require your Master Password less often: https://support.1password.com/android-biometric-unlock/.

    I hope that helps clarify everything, and let me know if you have any further questions! :)

  • Hi @kennyvl , I'm also facing the same issue and, by now, the only solution I've found is to minimize 1Password without closing it. In other words never use the close button (X), but always minimize the window (_).

    Unluckily, at the moment, the fingerprint sensor available on some Chromebooks can only be used to unlock them from sleep, but its APIs are not (yet) exposed to the Android stack.

  • periperi

    Team Member

    Thanks for sharing, @lammoth! Indeed, the Master Password will be required when relaunching 1Password any time it's fully exited. It needs to be left running in order for the PIN to be used.

  • I don't fully agree since I disabled 1Password's auto-lock settings inside the app.

    On my main computer, a Mac, 1Password behaves as expected: I can quit 1Password (fully quit, hence CMD+Q) and next time it's launched, it won't ask me for credentials as I have disabled auto-lock. Until the next full computer restart, that is.

    I would have expected similar behaviour on Chrome OS.

  • ag_anaag_ana

    Team Member

    @kennyvl:

    On my main computer, a Mac, 1Password behaves as expected: I can quit 1Password (fully quit, hence CMD+Q) and next time it's launched, it won't ask me for credentials as I have disabled auto-lock. Until the next full computer restart, that is.

    Cmd+Q does not fully quit 1Password for Mac, it only quits the actual app, but 1Password mini remains running. This is why you can relaunch the app and see it unlocked. Fully quitting 1Password for Mac is done with the Control‑Option‑Command‑Q keyboard shortcut, which will prompt you for your Master Password the next time you launch the app.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file