Unable to sign in from Android

1Password app (7.7.3) won't sign in on Android.

It scans my QR code, lets me type in the master password and then spins forever.

There's practically no network activity and adb logs aren't telling me much.

I've tried reinstalling the app, clearing the cache and settings to no avail.

I would use WLAN sync from Mac but recent versions don't seem to include it anymore?

Phone is running Lineage OS 17.1, if it matters

Comments

  • ag_anaag_ana

    Team Member

    Hi @corv! Welcome to the forum!

    Is this happening on WiFi, or on the mobile network? In either case, if you switch from one to the other, do you see the same behavior?

  • Hi @ag_ana thank you

    I tried as you suggested, still no dice. It seems the app has connectivity, as using a wrong password or sign-in address brings up the corresponding error messages

  • ag_audreyag_audrey

    Team Member

    Hey @corv, I'm sorry to see you're unable to access your Android app.

    Could you clarify if you see a spinning circle or if you see an error message? Could you tell us the exact error message you see?

  • Hello @ag_audrey

    When I enter my details correctly it spins indefinitely. I know my emergency kit is correct since it worked fine on Linux desktop recently.

    Thanks for the assistance, I don't know what else to try

  • ag_audreyag_audrey

    Team Member

    Hey @corv, have you ever been able to log in to your Android app? If not, do you know if you have any VPN or antivirus software on your Android device?

  • Hi again,

    I've never been able to log in on Android. I'm not using any VPN or antivirus software at the moment. I do have 2FA activated however.

  • periperi

    Team Member

    Hey @corv. Are you getting to the point where 1Password asks you for your 2FA code, or is it getting stuck before that? Also, could you try signing in from a browser on the same Android device? Are you having trouble signing in there, as well?

  • Hello @peri 1Password app never gets to the point where it asks for my 2FA code.

    Signing in from the browser works fine, using the same account details.

  • ag_audreyag_audrey

    Team Member

    Hey @corv, could you tell us which Android device model you have? It's possible that your device has built-in firewalls set that could be blocking the connection to our 1Password servers.

  • Hi @ag_audrey
    I think Lineage OS would have removed any such stock firewalls? Anyhow, I'm using a OnePlus Nord

  • periperi

    Team Member

    Hi @corv. I believe it does, though I'm not very familiar with this OS. Please keep in mind that custom ROMs can cause problems with 1Password, as it can change the bahavior of things we rely on. For now, tap Settings > Network & internet > Data usage > App data usage > 1Password > Cellular data & Wi-Fi data restriction options. Are you able to allow 1Password access there?

    If you're still having trouble, try signing in from a browser. From there, tap your name in the upper right corner, tap Get the Apps, then tap Add your account directly.

  • Hello @peri
    I've given 1Password "unrestricted data usage", all types of network access are enabled as you suggested.

    1Password app still won't sign in or even ask for my 2FA.

    I noticed something interesting however, comparing Firefox (Fennec) and Chromium (Bromite) behaviour on Android here:

    When signing in to 1Password.com, Firefox will prompt for my hardware 2FA key, while Chrome asks for a 2FA code.

    Perhaps having a hardware key enrolled is not playing nicely with Lineage OS, as you alluded to.

    I'm going to try disabling the hardware 2FA security key for now

  • Hi everyone,

    Removing my hardware security key second factor resolved the problem immediately.

    There is clearly a bug here somewhere but I'm glad 1Password can be used at all now, knowing this workaround.

    Thank you all for your support, I would have given up long ago otherwise!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file