1P Causes Auto-Fill to Hang

Ever since upgrading to iOS 14, I've had problems with auto-fill. I do not use Keychain or Apple's password management, I am 100% 1Password. I am currently using iOS 14.4 and version 7.7 of the iOS app.

When I go to fill a password, I experience a hang of at least 10 seconds... this is abnormal compared to my previous long-time experience with 1P on my Apple devices. Furthermore, this hang is experienced when trying to modify any Password settings in the device.

Steps to reproduce on my devices:

  • Go to settings
  • Tap "Passwords" and unlock
  • Tap on "AutoFill Passwords" the box turns grey
  • Count to 12, then finally the next screen comes up (the screen that shows the AutoFill Passwords toggle and then "allow filling from" Keychain (unchecked) and 1Password (checked).

This delay also occurs whenever I tap anything while in this menu -- the toggle, checking or unchecking the "allow from," and even just doing nothing but returning to the previous menu. The same delay occurs every time I try to fill a password, whether in an app or in Safari.

I have blown out Safari, made no difference. I have done multiple hard resets on the device, made no difference. Tonight I decided to try deleting the 1Password app from my device... that is when I became convinced the problem exists either with or due-to the use of 1Password.

I deleted the app, restarted the phone, and immediately had no problems accessing the AutoFill menus. The delay I previously experienced all went away. Great, I thought. Maybe I just needed to do a fresh install of the app. Nope. I installed the app, and the problem returned right away. I use two vaults, both synced using Dropbox. However, this issue wasn't the result of Dropbox or of using two vaults because the hang presented itself before I had even added a single vault. Just the presence of the 1Password app on my iPhone caused the AutoFill features to begin experiencing the 10-second hang.

I can't possibly be the only person experiencing this, right? It happens on WiFi, it happens on cellular, it even happens in Airplane Mode, so it's not connection related. It's not vault related, nor method of synchronization related, It seems to be just the presence of 1P on my device.

Thoughts?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • ag_anaag_ana

    Team Member

    Hi @eFlat7!

    I must admit, I have never seen this before, or heard it happen. I have just tested it on my device and the iOS settings menu is responsive as usual. Normally I would suggest you contact Apple directly, since the problem is happening outside of 1Password itself, but I suppose it won't hurt to look at some 1Password logs to see if we spot anything there.

    I would like to ask you to generate a diagnostics report from your iOS device and email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • eFlat7eFlat7
    edited February 23

    Hi ag_ana. I'm very glad to hear the problem isn't occurring on your device, but I am still perplexed as to why it's happening on my devices. In reading the thread on your apple-4280 issue from 2019, the symptoms are very similar to that. Like the reports in that thread, I used to think the password box just wouldn't show up until I force closed the apps and kept trying until it did. Eventually I discovered the 10-second delay. It's not that the password auto-fill prompts aren't showing up or that the keyboard has crashed, it just hangs for about 10 seconds and then the keyboard unfreezes and the auto-fill prompt shows up. Again, very similar to what's described in an old 1Password issue (apple-4280).

    Furthermore, it's almost like what is described in this issue: https://1password.community/discussion/comment/586778 . I'm not sure what the OP means about changing passwords, but the symptoms are exactly like what I'm experiencing.

    That is a thread you also responded to and stated it wasn't happening on your end. That's great and all, but it's clearly happening to some people. More than just me.

    Also, to your point that it's happening outside of 1Password itself, yes, this is true... to a point. The freezing keyboard, and the AutoFill delays disappear if I delete 1Password from my device. Also, this is occurring on all of my iOS devices, so while it is happening outside of 1P per se, it is clearly related somehow.

    The ticket number I received is: #HQI-88815-791

    I also included a video that shows the delay in the AutoFill settings because the "button" turns grey when it's tapped and it's the only visual indicator to show you the amount of time between when I tap on something and when the device unfreezes.

    Thanks for your help!!

  • ag_anaag_ana

    Team Member
    edited February 23

    @eFlat7:

    That is a thread you also responded to and stated it wasn't happening on your end. That's great and all, but it's clearly happening to some people. More than just me.

    For clarification, I am not saying this because I don't believe you: I need to be able to reproduce an issue if I hope for our developers to have a chance to address it. And the first step in reproducing an issue is trying it on my device ;) So that is the reason for my tests :+1:

    The ticket number I received is: #HQI-88815-791

    Thank you! I confirm that I have managed to locate your diagnostics report in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: HQI-88815-791

  • Getting a response from the support ticket, wanted to post a follow-up here to let anyone else know what we've discovered.

    This MIGHT be related to the fact that I have not upgraded to two-factor authentication (and I do not intend to as long as Apple gives me the option not to). I don't know why or what's happening behind the scenes causing this issue, but that does appear to be what's going on. Through a series of trial and errors, here's what I've found out:

    • Deleting 1Password from my iOS device and staying signed into iCloud, I have no problems.

    • Signing out of iCloud on my iOS device and installing 1Password, I have no problems.

    • Installing 1Password AND being signed into iCloud (at least, without 2FA enabled), that's when the problems occur.

    So, I don't know if this is an Apple-only problem, but there is a direct correlation between 1) not having 2FA enabled on my Apple ID, 2) being signed into iCloud on my iOS device, and 3) having 1Password installed. All three of these things being true creates the issue. If I take 1Password out of the equation, or I take iCloud out of the equation, the problem goes away. I don't have any faith this will be corrected, so I may just need to explore alternatives for password management. But, as I told support in the email, at the very least I hope 1Password raises the issue with Apple through their developer channels... whether Apple cares to fix it or not (doubtful), they should at least be made aware of it.

    In summation... basically, there isn't a solution other than me upgrading to 2FA (and support only thinks that's a "might fix," not a "will fix")... and that's not something I'm willing to do.

    Thanks!

  • I wrote this whole long response, but it seems to have disappeared on my end... so if it shows back up and looks as though I'm double-posting, that's why.

    Basically, support thinks this MIGHT be related to the fact that I don't have two-factor authentication enabled on my Apple ID. I have no intention of enabling it either, so that's pretty much the end of it.

    But for others who may read this, here's what we know: being signed into iCloud on your device (without 2FA enabled) and having 1Password installed causes the problem. If you remove 1Password the problem disappears, OR if you sign-out of iCloud, the problem also goes away.

    If my other post ever shows back up, I provide just a little more detail, but this is the gist of what the problem is... and probably nothing can be done about it other than me enabling 2FA ... which support still says is a "might fix" not a "will fix" and it's not something I'm willing to do anyway.

  • ag_anaag_ana

    Team Member

    Thank you for the update @eFlat7! In case you decide to give Apple 2FA a try, please let us know if the behavior changes :+1:

    Out of curiosity, may I ask why you are so against enabling 2FA for your Apple account?

  • Hi Ana, sorry for the delay in my response, just lost track of time.

    TL;DR - because I don't want to. HAHA.

    Basically, my resistance towards 2FA on the Apple account is three fold:

    1. I do not like the way it's implemented. Should Apple have chosen to allow us to use an authenticator app, like the one built-in to 1Password, it would significantly increase my willingness to enable it. Having to have a second Apple device with me in order to log into my own Apple account on my own Apple device is nonsense to me.
    2. As a matter of principle. Apple has gotten increasingly more "Microsoft-y" over the years -- instead of just taking our money and letting us decide how to utilize their products and services in a way that meets our needs, they are telling us what's best for us and how we should use their products and services. I am completely resistant to being told what to do (and how to do it) with the products on which I spend my own money. With each passing new update or upgrade to something, Apple is changing things and doing so in a manner that not only adds few usable features to my personal experience, but there's always some little catch... something that, may be small, but that "fixed" a problem I didn't have and changed something I didn't ask to be changed ... and usually, they spend so much time working on new features, they have no time left to actually provide a finished and non-buggy product. Furthermore, they disallow the user a choice to return to the way it was before (i.e, once you upgrade your iOS, you're prevented from going backwards; once you enable 2FA, you can't undo it... sort of). If I could go back to iOS 13, I would. I didn't have this problem before the upgrade and iOS 14 has added exactly zero features that are personally usable to me.
    3. I frankly don't feel 2FA is needed nor warranted. Having 2FA on my bank account? That makes sense. Having 2FA on my Apple account, seems a tad excessive. I don't store anything in iCloud, I don't save my photos there, I don't save my Apple Wallet there, I don't really think it's something I need additional layers of security to "protect." I was perfectly happy with the email telling me my account has been accessed on a new device and if it wasn't me, to call this number. That worked. It wasn't broke. Why "fix" it?? I'm EXHAUSTED with everyone and their brother deciding their specific service mandates using 2FA. Oh, what I wouldn't give to just be able to log into a website with a username and password anymore... but no. I have to login, wait for a code, spin around 3 times, recite the Pledge of Allegiance... backwards... and then .... uh oh, sorry, you timed out, let's start again.

    Of course I exaggerate significantly in that last point, but the use of 2FA on most accounts is about as necessary as those super long CVS receipts, and only mildly more beneficial. (I'm not sure that you're USA based, so to explain: CVS is a drug store notoriously known for having ridiculously long receipts with only about 15% of that real estate devoted to your actual transaction, the rest is mostly superfluous and impertinent.)

    I'm not a 80 year old grump who longs for the days of MS-DOS and a 56k modem... although people still compare me to that old man from the movie "Up" (and I'll take it). I know things change, I know things improve, and I know adding extra layers of security are (allegedly) designed to protect me, the user (although I submit that it's really designed to protect the service provider's assets or liabilities, because I don't believe many companies actually give a hoot about the user at the end of the day). I am just burnt out with 2FA and especially when I don't feel it adds to my experience. When presented with a choice, 7 out of 10 times, I opt not to enable 2FA... except now, Apple is pulling another trick from the Microsoft handbook and blocking me from certain services (e.g., HomeKit) unless I upgrade, and now, for some inexplicable reason, they are causing me this inconvenience... likely because of some coding blunder, but since it's their opinion that I should be on 2FA anyway, "and why would anyone choose NOT to implement 2FA when we told them it's better for them," they aren't at all interested in devoting any resources to correcting their error.

    I've been loyal to Apple since my very first Mac, the Quadra 650. I've been on the Apple bandwagon since WAY before the iMac was a thing.... since before Steve Jobs returned to Apple (actually, my first "mac" was a PowerComputing clone, when those were authorized and a thing sold in stores... but that's a conversation for another day)... it's just things like this (among other things, I assure you) that makes me question whether Apple still cares about users like me, or if I'm better off transitioning out of the eco-system. Now that they have gone mainstream, I feel their focus is moving in a direction opposite us creative types who kept them alive during the lean years.

    So.... there is my entirely too-long and only mildly off-topic response to your simple question. Haha. Thanks for your help. Who knows, maybe I'll finally acquiesce (by choice or force) and enable 2FA some day, and if that fixes the problem -- or if any other series of things fixes it -- I'll be sure to report back.

  • ag_tommyag_tommy

    Team Member

    @eFlat7

    although people still compare me to that old man from the movie "Up" (and I'll take it).

    Side note for a 50 something-year-old. I love "UP." I might give it a watch tonight. Thanks for the recommendation. I always think of Walter Matthau when I think of the guy from UP. Or he and Jack Lemmon in Grumpy Old Men. I can't believe we lost those legends 20 years ago now. It seems just like yesterday. I know some of my colleagues may be Googling Walter Matthau or Jack Lemmon about right now. :(

    Thank you for taking the time to share your thoughts and point of view. Please let us know if you give it a try.

  • Same issue. something definitely is wrong.

    I'm experiencing a stuck/hang situation on two Apple Devices (iPhone, Macbook Pro) and here's the situation on the devices:

    • iPhone 12 Pro (OS 14.4.1): Hanging in Chrome/Safari while trying to click on an input field
    • Macbook Pro 2018 (OS: Big Sur 11.2.3 (20D91)): Hanging in Safari while trying to click on an input field

    Should be noted I tried to check the browser's inspect tools logs but had no result. There's not much to report and not sure where 1Password logs placed on my devices to report it as diagnostic information. This bug made me crazy every time filling a form.

  • ag_anaag_ana

    Team Member

    @masoudgh:

    There's not much to report and not sure where 1Password logs placed on my devices to report it as diagnostic information.

    Here are the instructions to diagnostics report from your iOS device. You can email it to us to [email protected], so we can take a closer look at why this is happening to you.

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Thank you for posting all the details. I have the exact same behavior as the OP. I first noticed it and didn't pay as much attention to it. It's a long delay either in the setting passwords or if I I'm in safari and have to hit the key icon. I also do not enable 2FA on my ios device. I'm just posting here to follow along since there is no resolution at this time. Thanks

  • ag_anaag_ana

    Team Member

    @r2d2:

    I also do not enable 2FA on my ios device.

    So it does look like 2FA might have something to do with this. Thank you for letting us know and for sharing your experience as well :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file