Firefox Extension doesn't work at all.

Browser: Firefox. 86.0 (64-bit)
MacBook Pro 2016
OS: Mac OS Big Sur
1Password Version 7.7

I have an extension for Firefox installed, there is a 1Password icon in the right top corner of the browser. But when I click on it - nothing happens. No pop-up login windows, no suggestion nothing. No response at all.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • Joy_1PJoy_1P

    Team Member

    Hey @valermit - sorry to hear you're having trouble with 1Password's Firefox extension. Just to check, which of our extensions do you have installed? Is it the one from this link here: 1Password for Firefox?

    As a first step, please quit Firefox and restart your Mac. If you're still having trouble after that, please let me know!

  • Hello Joy_1P, Yes, I did install the 1Password extension from the link you have provided. I did restart FireFox and my Mac. It still doesn't work. There is no any response when clicking 1Password icon in FireFox.

  • ag_anaag_ana

    Team Member

    @valermit:

    For confirmation, do you by chance have Firefox configured to Never Remember History? If I am not mistaken, I remember a similar behavior quite recently, which was fixed by allowing Firefox to remember history.

  • I have the same issue. I just tried today, installed the link from the location above. Remember history is on for Firefox. Shutting down Firefox, and shutting down and restarting my MacBook Pro did nothing. This is an M1 MacBook Pro running the ARM version of Firefox.

  • ag_yaronag_yaron

    Team Member

    Hey @blackshield ,

    Can you please elaborate on the ARM version of Firefox? Which version is that exactly?
    If you install the stable version of Firefox, does everything work as expected? https://www.mozilla.org/en-US/firefox/download/thanks/

  • The ARM version IS the stable version for an M1 MacBook Pro. Its the version that will install automatically from FireFox website. Its just ARM based.

  • ag_yaronag_yaron

    Team Member

    Thanks for confirming @blackshield .
    Can you please try the following:

    1. Create a new user profile in Firefox: https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles
    2. Switch into the new user profile.
    3. Install only 1Password in it: https://support.1password.com/getting-started-browser/
    4. Make sure that Firefox's privacy settings are set to "Standard" and that Firefox can remember history, then test 1Password.

    Does that work properly or are you still getting a non-responsive 1Password icon?
    When you are done testing you can go back to your main user profile if you'd like.

  • This made no difference. I followed all instructions for creating a new profile, installing the 1Password add-on, and Firefox privacy is set for standard and it can and remember history is on.

  • ag_yaronag_yaron

    Team Member

    Thanks for the update @blackshield .

    Can you please send us the following via email:

    Send it to [email protected] alongside a short description of the issue and a link to this discussion here.

  • Its working now. I set it up on Firefox on a Windows PC, and when I went back to the Mac, it was working finally. Weird.

  • ag_yaronag_yaron

    Team Member

    Thanks for letting us know.
    If you encounter the issue again, please send us the logs so we can investigate.

    I hope you'll have smooth sailing from here on out though :)

  • I have the same issue. I switched up from Chrome to Firefox on MacOS Big Sur (Mac Book Pro 2019 Intel). In Chrome extension worked fine, but in Firefox when I was pressing on 1Password icon nothing is happening.
    The icon is not displayed on the forms on the sites. When I click in the context menu, nothing happens. I made the recommendations above, in the console I get the following messages.

    📤 Sending <NmShowUnlock> message to native core <2654810741> background.js:2:1790470
    📥 Received message <Nothing> from native core <2654810741> background.js:2:1789351
    📤 Sending <NmShowUnlock> message to native core <1975016721> background.js:2:1790470
    📥 Received message <Nothing> from native core <1975016721> background.js:2:1789351
    📤 Sending <NmShowUnlock> message to native core <4175956019> background.js:2:1790470
    📥 Received message <Nothing> from native core <4175956019> background.js:2:1789351
    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. 4 background.js:23
    Incorrect argument types for tabs.get. storage.js:135
    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. 3 background.js:23
    

    The classic extension works.
    I also tried rebooting, disable/enable extension and Extension Helper. But nothing helps. Firefox and 1password versions are latest.

  • ag_anaag_ana

    Team Member
  • Yesterday I disabled 1password app integration in the extension settings and signed in through the web. Then I enabled integration again and now it works as expected. One could say it solved the problem, but I wouldn't say it's clear to the user.

  • ag_anaag_ana

    Team Member

    Thank you for the update @KarmicDude! Understood, keep us posted in case you notice this again :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file