Android app asking for security key

kakkak
edited March 12 in Android

Hello. I have noticed over the past week that my android app randomly stopped syncing, so I signed out and tried to sign back in. When I do that, it asks me to use my authenticator (Authy), but doesn't accept the autogenerated passcode and then asks me to set up a security key. .... I use a security key on my laptop but not with my android app. What should I do? Seems like I can't get back into the app on my Android.
Thank you


1Password Version: 7.7
Extension Version: 4.7.5.90
OS Version: OS high sierra 10.13.6
Sync Type: Not Provided

Comments

  • @kak It doesn't make sense to be asked to set-up a Security Key after failing an authenticator based two factor authentication challenge. Is it asking you to confirm your Secret Key?
    Do you have Authy installed on any other devices? Do the codes generated by the other devices agree?

  • I am glad to know I'm not the only one who thinks it doesn't make sense to be asked to set up a security key. It was not asking for the secret key (I double-checked that). I only have Authy on my mobile device. Not sure what to respond to the question about codes on other devices .... thank you for your help!

  • @kak Its good to have Authy on more than one device, for example, in case you lose your phone. You could try downloading the Authy app for the MacOS and seeing if the codes generated on the Mac match those generated on the Android device.

    https://authy.com/download/

  • Thank you @missingbits . I have done this. But the phone is now no longer asking me for a key or authenticator code ... it's now just on the spinning wheel of death seeming to endlessly be trying to sync but never able to. Maybe I should delete the app and reinstall?

  • @kak This is not something I have come across, but in the same situation I would uninstall the app and delete all its data, re-start the phone and re-install the app. The quickest way to sign-in the to the newly installed app is using the setup QR code displayed at the following page:

    https://my.1password.com/profile

  • Thank you @missingbits

  • So I deleted the app and reinstalled it. The app saw that I have an account with 1Password, asked for my master password, and then again asked me to use my security key (with no other options). After some time of not following the prompts, it auto-directs to ask me for my 2-factor authentication, which I provide from the Authy app .... and then it tells me me the code is wrong. It makes me sign into the account again and when I put in my master password, it just loops back around again to asking for the security key ..... Seems like a loop I can't escape. Any more ideas @missingbits ?

  • @kak Did you re-start your phone between the uninstall and re-install? Do the Authy codes on the Mac agree with those on the phone?

  • @missingbits Yes, the codes agree. I have now uninstalled, restarted the phone, and re-installed. Once I sign in with my existing account, it's still automatically prompting me to use a security key with 1Password. When I wait for that prompt to time out to bring me to my Authy credentials, it says that they are unable to verify the credentials. So, basically it's the same loop of bugs on repeat.

  • @kak I would be tempted to turn-off two factor authentication, but first you might want to try removing the security key by going to the following page:

    https://my.1password.com/profile/2fa

  • Wow! Turning off 2FA and removing the security key worked. My account is now fully synced on my app.
    Next question: can I turn 2FA back on and reinstall security key?
    Thanks for your help @missingbits

  • @kak I'm glad that worked. You should be able to turn it on again as you only need the code when authorising a new device. Double check that 2FA is turned-off then delete the old 2FA token from Authy before adding the new one.

  • Thanks @missingbits . Yes it does look like the app stops working when I add the 2FA (as in, it goes back into the loop of not being able to confirm credentials). Seems like a bug at this point .... ? How to report?

  • @kak That's a shame. Probably best to disable 2FA and email a diagnostics report from the Android app with a link to this discussion.

    https://support.1password.com/diagnostics/

  • OK thank you @missingbits

  • ag_anaag_ana

    Team Member

    @kak:

    I just wanted to say that I have found your message in our system :+1: However, I see that you sent us a diagnostics report from your Mac. If you are still seeing the issue on an Android device, can you please send us a diagnostics report from your phone too?

    ref: AZN-15519-183

  • Just sent @ag_ana . Did you receive?

  • ag_anaag_ana

    Team Member

    Yes, thank you @kak :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file