No luck changing the keybindings

Hi,

I had to open a new thread since the original thread is closed. I've the snap package installed on my Ubuntu 20.10 workstation. The app doesn't allow me to change its keybindings so I had to find the JSON file and edit it. I think the file path is: $HOME/snap/1password/current/.config/1Password/settings/settings.json

I've edited the file like below:

{
  "$schema": "https://onepassword.s3.amazonaws.com/schema/settings.json",
  "ui.routes.lastUsedRoute": "{\"type\":\"ItemList\",\"content\":{\"unlockedRoute\":{\"collectionUuid\":\"OWHYY4XA2RF7JDTO3PDBAQ6NSU\"},\"itemListType\":{\"type\":\"AllItems\"},\"category\":null,\"sortBehavior\":null}}",
  "security.authenticatedUnlock.enabled": true,
  "privacy.checkHibp": true,
  "browsers.extension.enabled": true,
  "advanced.EnableDebuggingTools": false,
  "keybinds.open": "CmdOrCtrl+Shift+."
}

So I wanted to use Ctrl+Shift+. for showing/hiding 1Password but it doesn't seem to work. I use X11 btw.


1Password Version: 8.0.28
Extension Version: 1.23.1
OS Version: Ubuntu 20.10
Sync Type: Not Provided

Comments

  • Dayton_agDayton_ag

    Team Member

    Hi @tunix, I'm really sorry you're running into this issue! Let's see if we can get this running for you.

    I tested this out myself on 20.10 with the shortcut CmdOrCtrl+Shift+. and was able to call 1Password to the front when it was running - I confirmed that my code was a character-for-character match to yours, so I believe your json is set up correctly.

    Could you try changing the shortcut to something else temporarily, just to see if it's a problem with another app on your system grabbing the shortcut?

    Did you install 1Password via Terminal, as well as the Snap store? If so, could you check for ~/.config/1Password/settings/settings.json, and add the keybind option there as well?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file