1password mini will not recognise or fill sites in Google Chrome, but fine in Safari.

Background

I've been using 1Password in Chrome on my MacBook Pro for about a year now and it usually works perfectly. If there's ever a problem, it usually resolves within a minute or 2.

In Chrome, I have the 1Password extension but I also have the mini 1Password thing in my MacBook's menu bar. Usually when I go onto a site that I want to input my login details for I use the Cmd + / shortcut and that opens up the mini menu bar 1Password, which recognises the specific website and autofills.

For the past year I think I either haven't been utilising the chrome extension, or perhaps it's recently updated because I've only recently (after this problem) noticed the 1Password symbol in the actual login inputs on the web and started using it - previously I just used to use the keyboard shortcut and the menu bar 1password would do it's magic. I thought the extension was just there to help the menu bar item work properly in chrome, not for any actual functionality.

Problem

Now when I use Cmd + / in Chrome, the menu bar 1password opens but it will not detect which site I'm using - I have it set to open onto "Suggestions" but the suggestion is just "googlechrome" (which returns no results), not the specific site I'm on like it always has done in the past. If I search for the site I'm on, it comes up but the link for it says "Go" and if I click that, it just opens the site in a new tab but still doesn't fill it out.

Now the thing is, as I said previously, the Chrome extension seems to have either updated or I've started using it properly because i can click on the little symbol that comes up on login inputs on the web and it will autofill.

So actually, I can still use 1Password through the Chrome browser extension right now, I just can't use it with the keyboard shortcut. That's my problem. It's not massive, but since I use the keyboard to navigate most of my computer, it is quite annoying.

Potential causes

This only started happening after I used the app "Grand Perspective" to do a scan of the storage on my Mac and I restarted the Mac. When my Mac started up again, I got a couple of potentially related messages (paraphrased as I don't remember the precise wording):

  1. Google Chrome is an app created by Grand Perspective. Are you sure you want to open it?
  2. (From 1 Password) Google Chrome cannot be verified as a browser, please move it back into the Applications folder.

What I've tried

I've reset my 1Password, uninstalled and re-installed Chrome and restarted my Mac a couple of times. Nothing has changed.

Sorry for the essay but I think that's all the info I have.

Just to clarify, I'm looking to either fix the menu bar mini 1Password or to map the Cmd + / shortcut to the browser extension (or both).


1Password Version: 7.8
Extension Version: 1.24.0
OS Version: OS X 11.2.3
Sync Type: iCloud

Comments

  • ag_michaelcag_michaelc

    Team Member

    Hey @crustycrustycrustoid. It sounds like you have the new 1Password for your browser installed, rather than the classic extension. Currently it does not connect to the desktop app, which is why the keyboard shortcut and mini appear disconnected from your browser experience. The keyboard shortcut for the browser is different — give Shift-Command-X a try, and you should see 1Password in your browser (rather than mini from the desktop app) open up and show your suggested items. :smile:

  • Hi there,

    I'm experiencing the same problem but I have an additional hiccup which is making using 1Password quite frustrating. If I try to use the chrome extension, that can only see the 1Password account vault, but it doesn't see my primary vault which is in Dropbox. So using the Shift-Command-X shortcut does bring up the search bar, but I can't find any of my login entries.

    From the mini desktop app option, when clicking Command+\, it loads, but behaves the same as described above:

    • doesn't recognise the site
    • only has "Go" which just opens the tab rather than previously it had something with "Autofill", which would fill the form on the page you were already on

    Any advice, suggestions would be much appreciated.

    Same versions as the above user:
    1Password Version: 7.8
    Extension Version: 1.24.0
    OS Version: OS X 11.2.3
    Sync Type: Dropbox

  • ag_anaag_ana

    Team Member

    @clubsaads:

    You are right, 1Password in the browser only works with 1Password.com vaults. If you would like the extension to see also standalone vaults, you need the classic extension:

    Get the 1Password classic extension

    This will also make the extension work the way you want to when you use the keyboard shortcut ;)

  • Hi, that works now! Thank you @ag_ana. Just a quick question - I enabled both of the extensions and they seem to both work fine together, letting me use Cmd + /, and Cmd + Shift + X, as well as the 1password icon in login inputs. This is not a security risk or anything is it?

  • ag_tommyag_tommy

    Team Member

    @crustycrustycrustoid

    The only thing that comes to mind is occasionally they may not play well together. It has been a while since I saw that issue pop up. But it's something you should be aware of. I would recommend only have a single one active at any one time for that very reason. That said, if something should go haywire, quit 1Password completely, turn off both of the extensions and restart the browser then enable the desired choice.

  • ag_yaronag_yaron

    Team Member
    edited April 8

    It is more about confusion rather than issues when having both extensions. You will get double prompts to save new logins and you should know which extension is showing that prompt, when to ignore it and when not to. If you can't tell which is which, you might end up saving duplicates or not saving something at all.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file