Making 1Password and the built in Safari password manager play nicely together?

varencvarenc

I primarily use 1Password, but I also store some low-security passwords in the built in iOS/Mac password manager. This is mainly for convenience when accessing these services since the built in mechanism is a little quicker than 1Password. Or course anything real/important is in 1P.

So while I primarily use 1Password, I don't want to disable Safari's built in password manager completely. But my problem is they don't seem to play nicely together. See this screenshot:

As you can see, on a login page both show up but of course Safari's covers 1Passwords. If I press the "Esc" key, 1Password goes away but Safari stays. I can't find any keypress to make the Safari one go away but keep 1Password visible. I know the official documentation says to disable all Safari auto-fill features...but I'd rather not. Anyone have ideas?

(My hacky solution is to type in a letter that matches a 1P entry but not a Safari login entry. That keeps 1Password visible but makes Safari's passwords disappear. But it's that's a kludge.)


1Password Version: 7.8
Extension Version: Safari latest
OS Version: macOS Big Sur v11.01
Sync Type: Dropbox

Comments

  • ag_tommyag_tommy

    Team Member

    @varenc

    Try one of these options and see of they work for you.

    1. Disable the inline menu completely. 1Password > Preferences > Browsers - Safari, uncheck the option for show inline menu. This will cause 1Password to behave as it previously did before the inline menu.

    2. Disable the automatic inline menu popup. I use this on my Macs. 1Password > Preferences > Browsers - Safari - uncheck the option for "Automatically show the inline menu when selecting a field." Now, whenever you want to access the inline menu, you will need to click the 1Password icon in the field.

    3. Temporarily hide the prompt until the browser is restarted or until you right-click the page and select show 1Password. When the inline menu is shown, click on "Suggestions" and select hide on this page. This is useful if you want the inline menu on other pages.

  • Thank you @ag_tommy! I just disabled the Safari in-line menu and it's a great solution for me. Hadn't even realized how much I liked the old way. I just press ⌘+\ now and select a 1P password, or use Safari's inline menu if I want that. Thank you!

  • ag_tommyag_tommy

    Team Member

    @varnec

    As long as you have a solution that fits your needs, that's all that matters. It's all about finding that perfect fit. :wink:

  • If I can add on, I would like to be able to leave inline options enabled but turn off 1P on certain sites, just as you can disable prompting to save on some sites. The use case is when you don't want prompts on a specific site (thissite.thisdomain.com) vs another where you do (promptme.thisdomain.com). 1P seems to look at the domain and then suggest because both are from thisdomain.com

  • ag_anaag_ana

    Team Member

    @barthrh:

    Thank you for the feedback! Perhaps this is something we can address in the future, but for now you are right that 1Password looks at the domain part of the URL.

    However, I wonder if you have tried clicking on the Hide on this page button that appears when you click on a form field?

  • @ag_ana, yes I tried using "Hide on this page" but it works only that one time. When you return to the page, the inline prompts are back. I would expect it to persist, but since I don't see any setting to manage the exclusion list (like for prompts to save), I assume it isn't saved. For now, it seems like all-or-nothing for inline so I've opted for nothing in the meantime, using the old cmd+\ instead.

    By the way, isn't it a security risk to assume that any password for a given domain is a suitable replacement for a password prompt on the same domain? There are many domains that host sites where a.thisdomain.com has nothing to do with b.thisdomain.com. Personally, I suggest a setting for "subdomain matching required" for those of us who don't want recommendations across subdomains. This could resolve the inline issue since, because I would have no saved password for that subdomain, it would not prompt.

  • ag_anaag_ana

    Team Member

    @barthrh:

    yes I tried using "Hide on this page" but it works only that one time. When you return to the page, the inline prompts are back. I would expect it to persist, but since I don't see any setting to manage the exclusion list (like for prompts to save), I assume it isn't saved.

    It should persist in that browser session, but I see what you mean. I have passed your feedback to the developers :+1:

    ref: dev/projects/customer-feature-requests#92

    Personally, I suggest a setting for "subdomain matching required" for those of us who don't want recommendations across subdomains. This could resolve the inline issue since, because I would have no saved password for that subdomain, it would not prompt.

    Thank you for the suggestions! I have also sent this to the developers, so they know you would like to see this :)

    ref: dev/projects/customer-feature-requests#31

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file