Blank dialog box when deleting local vault

TiagoTiago

Hi there,
When I try to delete an "on my Mac" vault, I get a completely blank dialog box and nothing else happens. The only way to remove the dialog box is to completely quit 1Password, and the vault is not deleted.
Attached is a picture of the box, although there's not a lot to it because it's... blank!
Can anyone help?

Thanks
TM


1Password Version: 1Password 7 Version 7.8.1 (70801003)
Extension Version: Not Provided
OS Version: macOS Big Sur 11.3 Beta (20E5231a)
Sync Type: 1Password account

Comments

  • ag_anaag_ana

    Team Member

    Hi @Tiago!

    I have tested it here and I was able to remove the vault. I wonder if the fact that you are running a beta version of macOS and the stable version of 1Password could have something to do with this. Do you have another Mac where you could test the same procedure perhaps?

  • TiagoTiago
    edited April 20

    Hi there,
    Unfortunately I don't have another Mac. I could create a new volume to install the stable macOS version, but that takes a lot of time! Maybe I'll just let it be and delete it further on when either a new version of macOS or 1Password comes along.
    Just one note: this local vault was the "leftover" of resetting (removing) a remote iCloud vault. May that be related?

  • ag_anaag_ana

    Team Member

    @Tiago:

    Definitely a lot of effort for that, no worries! I was just wondering if you had a way to quickly test this, since things worked on my machine (which is not running the macOS beta, so I asked myself whether the operating system could have something to do with this).

    Just one note: this local vault was the "leftover" of resetting (removing) a remote iCloud vault. May that be related?

    Do you mean that you reset your 1Password data in iCloud? But even in that case, I don't think that it would matter when deleting the vault.

    Out of curiosity, have you tried rebooting your system once already?

  • Do you mean that you reset your 1Password data in iCloud?

    Yes.

    Out of curiosity, have you tried rebooting your system once already?

    Also, but the problem remains.

  • I get the same kind of blank dialog box when I try to untick the option of having local vaults, in Preferences/Advanced

  • Sorry, another note: the vault I'm trying to delete is the only local vault, named Primary. I just tested creating another local vault, and was perfectly able to delete it.
    So the issue now is what I said above concerning the local vaults option.

  • ag_tommyag_tommy

    Team Member
    edited April 21

    @Tiago

    The developers are looking into the behavior. I'm sorry for the trouble you've had.

    --

    A potential solution would be to reset the Mac app and set it up from scratch while the developers investigate. As you indicated that you're looking to remove a Primary vault, that would lead me to believe you're using a membership. If that's the case, please use the following set of instructions.

    The following steps will remove all local data and allow you to set up the Mac app anew.

    • Be sure that you intend to remove all previous data before following these steps.
    1. Verify you can access https://my.1password.com and have a copy of your Emergency Kit. * Please double check and make sure all of your data is present.

    2. Open or bring 1Password to the front.

    3. Click on Help (at the very top of the screen to the right of the Apple icon) > Troubleshooting > Reset All 1Password Data. You will be asked to type in a code, and you need to copy it as is, hyphens included.

    4. Click on Delete Data and Start Over. * This only removes local data and doesn't affect your cloud data. At this point, 1Password will quit and disappear off your screen.

    5. Open 1Password again on your Mac, and there will be two choices - New to 1Password? Or Used 1Password before?

    • For 1Password.com memberships: Under 'Used 1Password before' select the 1Password.com option, sign in to your account. * If you see the option for signing into your old account, please use the section to sign into a different account.

    ref: dev/apple/issues#4883

  • Thanks! That worked!

  • ag_tommyag_tommy

    Team Member

    You're most welcome.

  • Hello,

    Same problem as the original post.

    Originally a "standalone" installation (i.e. no 1Password account) with one single local vault (Primary).

    Set up a Family 1Password account.
    Moved all entries from the local vault to the 1Password account (several vaults).
    Attempted to delete the (now empty) local vault.
    Blank window pops up.
    Have to completely quit 1Password to get rid of the blank window.
    Deleting other local vaults works as expected (tested by creating another local vault, then deleting it).

    Any news from the developers who (allegedly) have been investigating this issue since April?

    Regards,
    Radu

    1Password 7
    Version 7.8.1 (70801003)
    1Password Store

    macOS Big Sur 11.13.1

  • ag_anaag_ana

    Team Member

    @Radu:

    Can you try adding one Login item in this vault, and then trying to remove the vault at that point when it is not empty anymore? I see a comment from back when our developers addressed this that it could have been one of the causes for this behavior.

  • @ag_ana

    Thank you. That was it. Who would've thought?

    Also, I checked the release history and it turns out the bug was fixed in version 7.8.2.

    I've updated my 1Password installation and I can confirm that it is now possible to delete the Primary (local) vault even if it's empty.

    All good.

  • ag_anaag_ana

    Team Member

    Thank you for the update @Radu, that's great to hear :) If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file