Autofill filling / blocking numeric PIN entry fields

rkbonirkboni
edited April 30 in Android

I have an app to access my benefits info (FSA, HSA, ...) on my phone from iFlex / iSolved Benefit services. The app generally prompts for both username/password and a PIN. Recently I had to update my password, which forced me through the PIN change screens as well.

1Password had trouble filling in the username & password fields, but I was able to work around that by typing in my username and copy-pasting the password from the vault. Once logged in, I had to set a new PIN... here's where I got stuck.

On the first PIN page (initial reset), I was able to type in all 4 digits of my new PIN, and although the 1Password autofill popup was present I was still able to use the keyboard to enter the digits regardless.

BUT, on the "confirm PIN" page, I was only able to enter a single digit before 1Password froze me out for some reason. No further keyboard entry (either new digits, or erasing the first digit) worked, and the autofill popup did not go away. Occasionally, the autofill popup stayed around even though I went back to the prior screen or the start of the login flow.

I was hoping that by un-associating the 1Password entry from the app that I could get around that but that just loses the suggested logins and still shows the autofill popup. Finally had to turn off autofill to complete the signup.

Can we opt apps out of auto-fill? Is there something I can do besides turning off auto-fill every time this happens?

Thanks!
--rafal


1Password Version: 7.7.4
Extension Version: n/a
OS Version: Android 11 (Sec update 4/5/2021)
Sync Type: ?

Comments

  • ag_anaag_ana

    Team Member

    Hi @rkboni!

    Are you able to let us know what app this actually is? I think it would be nice if we could test it here too :+1:

  • Sure, it's https://play.google.com/store/apps/details?id=com.lighthouse1.mobilebenefits.ifs (hmmm, amusing that the store app name matches neither of the names I know it by 8-) )

  • ag_audreyag_audrey

    Team Member

    Hey @rkboni, I've tried downloading the app, but for some reason, it's just showing me a black screen when I try to open it. Would you mind sharing some screenshots of the Autofill prompt you're getting that keeps blocking you from typing?

  • Hi @ag_audrey! I wasn't able to take a direct screenshot in the app since it apparently disables it, but here's one taken of the phone via another device when I'm in that state. The other telltale sign that something is up is that the autofill prompt didn't time out like it usually does (good for taking screenshot, not so good for using the app).

  • One other thing I just noticed - this isn't standard Autofill doing this, it appears to be the accessibility based filler. If I just disable autofill I still get the autofill notification.. had to turn off the "accessibility" toggle to actually stop autofill from showing up in the app.

  • periperi

    Team Member

    Hi @rkboni. Thanks for the additional info.

    I wasn't able to take a direct screenshot in the app since it apparently disables it

    Screenshots are disabled within 1Password by default. This is what protects your data, and blocks 1Password from being visible when screensharing. If you ever need to, you can allow screenshots. Just launch and unlock 1Password and tap Settings > Advanced > Allow screenshots.

    As to the issue you're having, does the whole page seem frozen? If you tap outside of the PIN field--anywhere else on the page, does the Autofill prompt stay stuck on screen, or does that dismiss it?

  • rkbonirkboni
    edited May 3

    Hi @peri,

    I wouldn't have expected 1Password screenshot policy to apply within the app being filled. Does that apply there as well?

    The whole page does indeed seem frozen.. there isn't much else to interact with, but clicking outside the pin entry field doesn't change anything. Moreover, if I move off that page, e.g. by clicking the question mark icon on the top right, the 1Password autofill prompt stays on the screen and when I return from there (it takes me back to the beginning of the login flow), I will get two copies of the 1Password prompt.

  • periperi

    Team Member

    @rkboni It does. It applies anytime 1Password is on screen.

    Thanks for reporting this issue. I'll share the issue with the isolved Benefit Services iFlex app with our development team to look into.

  • Hi @peri,

    Thanks for the clarification of where the no-screenshot policy applies -- I've probably run into this issue before and not realized it was due to 1Password vs the specific app 1Password was drawing over! Thanks also for passing along the bug to your dev team!

    Cheers,
    --rafal

  • periperi

    Team Member

    @rkboni Happy to help! Thanks for reporting this!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file