Escaping "/" in secret names

Hi.

I'm trying to implement the Kubernetes Operator onto my cluster and I'm testing with the following yaml:

apiVersion: onepassword.com/v1
kind: OnePasswordItem
metadata:
  name: testerezda
spec:
  itemPath: "vaults/Vault Name/items/dev/databases/writer-user"

As you can see, my secret contains "/" characters.

How can I escape these with the operator?

Thanks
Mark


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • James_1PJames_1P

    Team Member

    Hi

    I do not believe that there is an option right now to escape characters in an item title for the itemPath in the current version of the operator. Please submit a feature request with the operator though because that would be a nice improvement.

    In the short term you can work around this limitation by using the UUID of the item in place of dev/databases/writer-user. This UUID can be retrieved using the Copy UUID feature in any 1Password Client or through the CLI

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file