Autofill not working on the android brave browser

After I upgraded to a samsung galaxy s21 ultra, 1password is no longer automatically selecting the autofill usernames and passwords for any website. I have to manually search for the username and password, at which point it will fill the username and password fields. It does not remember the username and password I selected the next time I go to log in to that website. I will have to manually search for it again.
This was previously working when using the android brave browser on my galaxy s9+.
I have autofill, accessibility, autofill previews enabled.


1Password Version: 7.7.4
Extension Version: Not Provided
OS Version: 11
Sync Type: Not Provided

Comments

  • Amber_agAmber_ag

    Team Member

    Hi @pharbian,

    I'm sorry to hear you're experiencing some issues filling in the Brave browser.

    Brave uses Accessibility to fill your credentials. To improve battery life, many Android device manufacturers have built-in optimization software that aggressively terminates processes, which can include the 1Password accessibility service.

    Check the following places to see if battery optimization is turned on for 1Password:

    Settings app > Device care > Battery
    Settings app > Applications. Tap ⋮ and tap Special Access > Optimize battery usage
    If battery optimization is turned on for 1Password, turn it off.

    Recheck your Autofill settings, if they're correct and you're still experiencing the same issue, turn them both off and on again.

    Check your Autofill Settings:

    1. Open and unlock 1Password
    2. Click the Settings tab at the bottom > Autofill
    3. Make sure both Autofill and Accessibility are turned on

    Let me know if you can fill your usernames and passwords with 1Password again.

    Please Note: Your battery optimization settings may reset after updating your device, so you’ll have to repeat this process for Accessibility to continue working.

  • pharbianpharbian
    edited May 12

    Unfortunately, your recommended steps did not resolve my issue. The behavior when using the brave browser remained the same. I am still only offered two options for the 1Password login window that pops up. Either "Search 1Password" or "Create a new login".
    If I am using the chrome browser, the 1Password icon shows up at the top of the Gboard keyboard. When I click on that, the 1Password window pops up showing the specific website I am using as an option. I click on that, and it fills the username and password fields.
    When using brave, I have to click on the search option, which then launches the full list of my saved passwords. I then have to either type to search, or scroll through the list to select the website into which I am attempting to login.

  • ag_audreyag_audrey

    Team Member

    Hey @pharbian, I'm sorry to hear Amber's above steps didn't help.

    Could you try going to your 1Password app > Settings > Autofill, turning off Autofill previews, and then turning it back on?

  • That fixed it!
    Thank you for your help.

  • ag_audreyag_audrey

    Team Member
    edited May 13

    You're very welcome, and thank you for the update, @pharbian. I'm glad everything's working as expected in Brave now 😊

    Let us know if you have any further questions!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file