Strange UI behavior in beta and stable release

When starting the browser (Edge Chrome, Firefox & Vivaldi) and clicking the 1Password in the browser icon the buttons at the top right look good. The spacing fits.

But when open any website and click the icon again the buttons moved to the right side. This looks a bit strange. There is no space left.

I have seen this behavior in Windows 10 Pro 20H2 in Edge Chrome, Firefox and Vivaldi, and it doesn't matter if I'm using the latest stable release 1.24.2 or the latest beta release 1.25.7.


1Password Version: Not Provided
Extension Version: 1.24.2 & 1.25.7 beta
OS Version: Windows 10 Pro 20H2
Sync Type: 1Password.com

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @DenalB ,

    I'm trying to replicate this here without luck. Here are my steps:
    1. I open Brave or Edge.
    2. I unlock 1Password by clicking its icon on the top right. The popup looks good.
    3. I then go to any website (e.g. google.com) and click the extension's icon again - the popup still looks good, same as before.

    Am I missing any steps?

  • NaxterraNaxterra
    edited May 20

    I have the same issue.

    But it happens when 1Password language set to German. In English it looks fine.

  • ag_yaronag_yaron

    Team Member
    edited May 20

    Nice catch @Naxterra !

    I was able to reproduce the issue when setting the extension's language to German.
    Bug filed. :chuffed:

    ref: dev/core/core#7627

  • But it happens when 1Password language set to German. In English it looks fine.

    Wow... Great finding @Naxterra ! Thanks for jumping in. :+1:

    Bug filed. :chuffed:

    Thank you very much @ag_yaron ! :)

    Great to have this community forum! :+1:;)

  • ag_yaronag_yaron

    Team Member

    Indeed! :chuffed:

  • Hey!
    I am liking the dark mode so far in the chromium extension. I found some rough looking rounded corners in the suggestion popup:

    Technical Background:

    this seems to be related the the "iframe" styling of the "com-1password-menu", which acts as a container for the popup. The default style (which is not altered by dark mode) contains a "background: white" setting, which slightly bleeds through here! Without that white background, the popup looks flawless!

    I didn't want to open a new discussion for this, since it's a small and nitpicky thing, but thought it would fit in here. ;)

  • ag_yaronag_yaron

    Team Member
    edited May 23

    Hey @LukenSkyne ,
    Thanks for reporting this! I'll check with our developers about this :)

    ref: dev/core/core#7662

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file