Browser extension update makes 1Password worse to use in browser

Hey guys, the recent update to the extension (Chrome Windows in my case) really sucks. It used to be when you unlocked 1P the window would stay open so you could just start typing the site you wanted and hit enter to go there. Very fast. Now I need to reach for the mouse, click the icon, head to the keyboard and type my password, reach for the mouse again to click the icon, head back to the keyboard to start typing the website I want... I know it might sound like a small deal, but as much as I use the extension this change really sucks. PLEASE devs can you fix this???

Comments

  • kaitlynkaitlyn

    Team Member

    Thanks for getting this on our radar, @Dave5150! Could you let me know which version of 1Password you're using in your browser?

    Another question – is the 1Password for Windows application unlocked when you click the 1Password icon in your browser toolbar, or is the desktop app locked at that time?

  • @kaitlyn I just tested it and it happens when the app is locked. In fact I rarely use the app, so the previous version of the extension didn't require the app to be unlocked either. One thing to note, there's no way that scenario is possible (app being unlocked but the extension being locked) because as soon as I unlock the 1P app, the browser extension immediately unlocks as well. The version I'm on is the latest for Edge on Windows (2.01) and the app version is 7.7.807 if that helps.

  • kaitlynkaitlyn

    Team Member

    @Dave5150 – I appreciate the clarification. I was able to reproduce the issue on macOS as well. I've passed the report along to our development team.

    In the meantime, what caused the change is a new feature we just released called Shared Lock State, which allows the 1Password desktop app and 1Password in your browser to share their lock state. However, if you don't often use your desktop app to begin with, that may not even be an appealing feature to you. If that's the case, you can disable the integration altogether by right clicking the 1Password icon in your browser toolbar, then disable the "Integrate with 1Password app" option. I did confirm that brought back the old behavior for me (granted, I'm on macOS).

    I hope that helps!

    ref: dev/core/core#7986

  • Thank you! I’ll give that a shot tomorrow.

  • ag_anaag_ana

    Team Member

    Sounds good, let us know how it goes :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file