Can't use 1Password to login SWTOR

On this page:
https://account.swtor.com/user/login?destination=home

when 1Password fills the fields, the login fails, the username is correct.
If I click on the password field of the app to copy it and paste it, it fails.
If I enter edit mode, then copy the password from the text field, I can log in.


1Password Version: 8.1.2-2.BETA
Extension Version: 2.0.5
OS Version: Win10
Sync Type: Not Provided

Comments

  • Hi @Geobomatic !

    I'm not able to reproduce this behavior. I tried the ENG and the GER website, and it worked.

    Maybe you could manually fill the fields and save the login as a new entry into 1Password.

    After that, try to log in with this newly created entry. Hopefully it works?

  • edited July 11

    I tried to create a new entry like you said, and no luck. I'm using Firefox if that can help (and the beta version of the extension).

    EDIT: just to add some info, both entries have the same password

  • OK found the issue: 1Password created a 20 chars long password for me, but it seems that the website truncated it to 16

  • Luck for me, my password is 16 chars long... That's why it works!

    So I have to think about it when creating a new password for this site. Thanks! :+1:

  • Dayton_agDayton_ag

    Team Member

    Hey there @Geobomatic, I'm glad to hear you were able to get this sorted! I'll pass this along to our Dev team to see what we can do to mitigate this from our end. Could you tell me how you generated your password for this website? Did you use a suggested password from 1Password in your browser, or did you generate it manually?

  • It was suggested by 1Password :)

  • Dayton_agDayton_ag

    Team Member

    @Geobomatic Ah, good to know! Have you tried out 1Password in your browser's Smart Password generator? Using the Smart Password generator, 1Password will try and determine the specific site's requirements, and will generate a password that fits. We've tested this out with this website and it gave us a random 16-character password.

    To use the Smart Password generator, open 1Password in your browser, click the key icon, then change Type to Smart Password and hit refresh to get a password fitting the new recipe. You can also check Use as default so 1Password continues to make smart password suggestions by default in the future.

    In the meantime, we've flagged this for the Development team to look into and see what we can do on our end. :smile:

    ref: /dev/core/core/#6078

  • I'll try that next time I need a password! Thanks for the tip!

  • PeterG_1PPeterG_1P

    Team Member

    We'll look forward to hearing what you think about it! 😀

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file