Firefox Nightly PPA doesn't communicate with app

I have 1Password for Linux 8.1.2-10.BETA installed, and have tested it with the system repository installed Firefox with the beta extension on Pop!_OS 21.04 and it communicated with the app perfectly. I then went and installed Nightly from the Ubuntu Mozilla Daily Build and the 1Password beta extension and it cant talk with the app.

I then tried the versions from Mozilla's site (stable/beta/dev) which are just archives that can just be uncompressed and ran, and they didn't work with it either. After talking with email support they suggested using "sudo chown -R root:root" on the directory since it needs to be owned by root for it to be able to talk with the app, and it worked for all 3 of those downloaded versions, but as far as I can tell, the system and PPA installed version is located at /usr/lib/firefox and usr/lib/firefox-trunk respectively, and both are already owned by root.

When I view the debug console for the extension I get the following:

💫 Looking for desktop app com.1password.1password background.js:2:1787756 👍 Finished initializing 1Password background.js:2:1856513 📤 Sending <NmRequestAccounts> message to native core <2235882486> background.js:2:1789800 Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. background.js:2 Received <BrowserVerificationFailed> from the native core

If it can talk with the app the " from the native core" would instead be " message from the native core"

That same error was shown on all 3 Mozilla downloaded versions too untill I made the extracted directory in my download folder owned by root.

Anyone have any ideas on how to get this Nightly PPA to play nice with the app integration?

Thanks!


1Password Version: Linux 8.1.2-10.BETA
Extension Version: 2.0.5
OS Version: Pop!OS 21.04
_Sync Type:
Not Provided

Comments

  • BaronKrauseBaronKrause ✭
    edited July 15

    SOLVED!

    Support got back to me, it ended up that the Nightly PPA did need to be added to a list of approved browsers since the PPA installs itself to run with "firefox-trunk" so it can run side by side with non nightly Firefox builds. Here was the process they sent me:

    1. Pop open a terminal, and run sudo mkdir /etc/1password (if you've done this already, you can skip it).
    2. Run cd /etc/1password
    3. Run sudo gedit custom_allowed_browsers
    4. Paste in the appropriate browser code - such as opera or vivaldi-bin. (in my case firefox-trunk)
    5. Save the file.
    6. In terminal, run sudo chown root:root /etc/1password/custom_allowed_browsers && sudo chmod 755 /etc/1password/custom_allowed_browsers
    7. Run 1Password - it will read our new config file and make the appropriate connections.

    Worked like a charm! 1Password support is top notch!

  • Dayton_agDayton_ag

    Team Member

    Hey @BaronKrause, I'm glad we were able to get this working for you! Feel free to write back in if I can help with anything else. :smile:

    ref: FLY-97147-749

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file