2FA Codes Don't Fill on Gitea

alexclstalexclst Junior Member
edited July 16 in 1Password in the Browser

I use a Gitea server as part of my work. While my username and password are filled appropriately via 1Password, I have noticed that 2FA codes aren't filled at all. Furthermore, the Login in 1P doesn't recognize the field, so I need to copy and paste the 2FA codes. Is this something that needs to be fixed in the software (I've seen similar notes in release notes before about filling fixes) or is there something about the Login item itself I need to change (like under saved form details)?


1Password Version: 7.8.6
Extension Version: same (I use Safari)
OS Version: macOS 11.4
Sync Type: Families

Comments

  • ag_chantelleag_chantelle

    Team Member
    edited July 17

    @alexcist

    I've tested signing into Gitea, and the way they have the TOTP field coded is a little ambiguous. When we scan the page, it can result as a false positive. I'll report this one to our development team to see if we can adjust the clues we use for autofilling here.

    In the meantime, if you edit your Login for Gitea and change the label for the TOTP field to passcode (case sensitive) it will allow 1Password to properly autofill your TOTP.

    Let me know how it goes. I'll be happy to help if you have any trouble.

    ref: ref: dev/core/core#8750

  • alexclstalexclst Junior Member

    Yes, that worked, to change the label in the Login for the TOTP field. Thanks.

  • Joy_1PJoy_1P

    Team Member

    @alexclst On behalf of Chantelle, you are welcome! Let us know if you have any other questions or run into any other issues. We're always happy to help.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file