1Password Extension Doesn't Load Completely

JALTTJALTT
edited July 17 in 1Password in the Browser

My details are as follows:

M1 Macbook Air
16GB
512ssd
Big Sur 11.4
Microsoft Edge 91.0.864.70 (Official build) (arm64)
1Password 2.0.4 (Latest Version I'm seeing in the Edge Extension store - Screenshot attached)
External Dell 1080p Monitor

I noticed that when the browser is on the Macbook display 1Password extension doesn't load completely. I wasn't quite sure how best to explain it so I made a screen recording - https://1drv.ms/u/s!AjGXVzekDHBboMcaZOCv2yHUXueLjQ?e=MDL8hj

If I move the browser to the external monitor it works as intended as can be seen in this screen recording - https://1drv.ms/v/s!AjGXVzekDHBboMcbQUm-XgK-iNYMew?e=aRI0W9

Really not sure if this is a fault of edge or 1password but thought I'd post it here just incase because it's the first time I'm noticing this since I have this laptop (maybe about 2 months now) and I use 1Password all day, everyday.

I should probably also mention that if the external monitor is not plugged in, 1Password extension loads fine on the Macbook display


1Password Version: Not Provided
Extension Version: 2.0.4
OS Version: Big Sur 11.4
Sync Type: Not Provided

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @JALTT ,
    Sorry for the delayed response, we're working on replicating your setup here so we can investigate the issue and see if we can reproduce it.

    Hopefully we'll have some news soon.

  • ag_jarekag_jarek

    Team Member

    @JALTT,

    Jarek here from the 1Password Extensions team. Thanks for bringing this issue to our attention! I was able to reproduce the problem you describe on my Macbook with an external display. It looks very similar to a rendering bug in Chrome that we had to implement a workaround a few months back.

    This bug happens in the following situation:

    • Have a macbook
    • Be connected to an external display
    • Make the external display the main display in macOS display preferences
    • Have Edge on the Macbook's internal display
    • Try to use 1Password in Edge

    It's unfortunately a rendering bug in Edge, so I'm not entirely sure if it's something we can fix on our end. Hopefully there's a workaround we can implement like there was for the similar Chrome issue. In any case, I filed an issue internally so that this can get looked at! In the meantime, you could potentially try making your Macbook's internal display the primary display in macOS display preferences. I didn't notice any issues using 1Password in Edge on either screen when that was the case.

    Thanks again for reporting this and please do let us know if you run into any other issues! :smile:

  • @ag_jarek @ag_yaron Thanks for the response. Happy to hear that you were able to replicate the issue and a solution could possibly be implemented,

    I did try making the internal display the primary display and the extension did work as it should have. I'm not sure if this arrangement would be best for my workflow but we'll see how it goes as a temporary solution.

    Thanks again!

  • ag_jarekag_jarek

    Team Member

    @JALTT anytime! Have a wonderful day :chuffed:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file