Using 1password extension with multiple chrome profiles

I've added the chrome browser extension to both chrome profiles, however when trying to sign into my 1pass accounts in the extension settings of my second chrome profile, I am unable to. I believe this is because I'm already logged into my 1pass accounts with the desktop app and my other chrome profile and so the chrome extension in my second chrome profile is somehow confused. Is this a known issue or am I missing something?

I'd like to be signed into both my 1password accounts in both my chrome profiles. All software is up to date


1Password Version: 7.8.6
Extension Version: 2.0.5
OS Version: OSX 11.3.1
Sync Type: Not Provided
Referrer: forum-search:ask

Comments

  • BenBen AWS Team

    Team Member

    Hi @bzawlocki

    I'm doing a similar thing on my computers, so it is possible. :) When you say:

    I am unable to

    Could you please elaborate? What specifically happens/doesn't happen? Is there an error message you're getting? Please let us know. Thanks.

    Ben

  • philb74philb74
    edited July 29

    Hi, I had exact same behaviour. Then I found out following.

    Just for the info:

    MacOS 10.15.7
    Chrome Version 92.0.4515.107 (Official Build) (x86_64)
    I have 4 different 1Password accounts successfully subscribed.

    On both Profiles:
    1Password Chrome Extension Version 2.0.5.
    All accounts/vaults are active in settings.

    Profile #1 (default):
    Everything works well. Browser can fill the login form.

    Profile #2 (default):
    Browser didn't find the item, no suggestions even when I clicked the 1password icon.
    When I opened the search on the extension icon, I could find the item.

    Settings for the browser extension were same for both profiles.

    Temporary Solution:
    I had to change something in the settings.
    I changed language for example.
    After reloading the page autofill is working until I restart the browser.
    When I restart the browser it won't work until I change some extension settings.

    Another problem on the chrome profile #2 :
    Two-factor authentication with one-time passwords. won't work even after changing any settings in the extension. So this never works on the profile #2.

  • ag_anaag_ana

    Team Member

    @philb74:

    Can you please send us some extension logs so we can take a closer look for you?

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • @ag_ana Thx, I've sent the logs. Ticket number [#WNH-35964-917].

    Best regards,
    Phil

  • ag_anaag_ana

    Team Member

    @philb74:

    Thank you! I confirm that I have managed to locate your message in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: WNH-35964-917

  • Everything seems to work after deleting and reinstalling the extension on this non working profile again.

  • ag_anaag_ana

    Team Member

    That's great to hear @philb74! Thank you for the update :)

  • edited November 24

    hello, I am experiencing the same issue, or a similar issue where I am not able to use 1password properly in the 2nd profile. it only works in the 1st/default profile.
    specifically I am able to see the extension in the tab, but the normal [Command + \ ] doesn't work, nor does the embedded login/pass feature in the forms. In other words, I have to go to the desktop app to copy/paste passwords.
    I also have a work/personal split, and my 'organization' (work IT) manages the extension, so wondering if that may be part of the issue... pls lmk if there are steps I can take to make it work on both sides!

  • ag_anaag_ana

    Team Member

    @jzwierzycki:

    If you ignore the keyboard shortcut for now, does the extension work as expected if you click on it in the second profile?

  • Hi @ag_ana ! Thanks for the quick reply.
    It does not work completely, no: when I click it, the helper/window does pop up, but when I click 'auto fill' rather than filling, it instead pops up a new tab for that site, and does not fill that one either.
    Another thing that's weird, sometimes when I do the copy/paste workaround, I'll then get a pop-up asking if I'd like to save the login to 1P (even tho it's already registered).

  • ag_anaag_ana

    Team Member

    @jzwierzycki:

    It does not work completely, no: when I click it, the helper/window does pop up, but when I click 'auto fill' rather than filling, it instead pops up a new tab for that site, and does not fill that one either.

    Can you try installing the new 1Password in the browser extension in this second profile, instead of the classic browser extension that you currently have installed?

    Another thing that's weird, sometimes when I do the copy/paste workaround, I'll then get a pop-up asking if I'd like to save the login to 1P (even tho it's already registered).

    This happens when the URL inside the 1Password Login item is different from the URL of the website that is open in the browser. Can you check if the two URLs actually match?

  • hello again @ag_ana
    your first tip seems to have worked! I now have 2 versions of the extension in the second profile, but they do not appear to conflict.
    I am able to use the shortcuts and so on, I think I'm good to go thank you!!

  • ag_anaag_ana

    Team Member

    @jzwierzycki:

    your first tip seems to have worked!

    That is great to hear, thank you for letting me know :)

    I now have 2 versions of the extension in the second profile, but they do not appear to conflict.

    They shouldn't, but you can remove the old classic extension, and just leave the new one installed, since you won't need both ;)

    I am able to use the shortcuts and so on, I think I'm good to go thank you!!

    You are very welcome :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file